summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-11-20 17:17:14 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-11-21 18:58:00 +0100
commitc44782e9708067acfc7620cf1b2585f5374e32c0 (patch)
tree95fcd0075381f1718cece354823ec5a93312a249
parent1574be2de6d82a49b88470ab1881b96f332bbeb7 (diff)
Machine: use the changed machinename colibri-vf
-rw-r--r--recipes-bsp/alsa-state/alsa-state/colibri-vf/asound.state (renamed from recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state)0
-rw-r--r--recipes-bsp/u-boot/u-boot-colibri-vf.bb33
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb13
-rw-r--r--recipes-support/fbset/files/colibri-vf/fb.modes (renamed from recipes-support/fbset/files/colibri-vf50/fb.modes)0
4 files changed, 14 insertions, 32 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state b/recipes-bsp/alsa-state/alsa-state/colibri-vf/asound.state
index 7d61d15..7d61d15 100644
--- a/recipes-bsp/alsa-state/alsa-state/colibri-vf50/asound.state
+++ b/recipes-bsp/alsa-state/alsa-state/colibri-vf/asound.state
diff --git a/recipes-bsp/u-boot/u-boot-colibri-vf.bb b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
index ae2ddc8..cd84206 100644
--- a/recipes-bsp/u-boot/u-boot-colibri-vf.bb
+++ b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
@@ -11,36 +11,19 @@ PR = "r0"
S = "${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_colibri-vf50 = "ac13ca97df9f8c17d1c89d425041690484ee0fdf"
+SRCREV_colibri-vf = "ac13ca97df9f8c17d1c89d425041690484ee0fdf"
#FILESPATHPKG =. "git:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "colibri-vf50"
-DEFAULT_PREFERENCE_colibri-vf50 = "1"
+COMPATIBLE_MACHINE = "colibri-vf"
+DEFAULT_PREFERENCE_colibri-vf = "1"
-# colibri_vf50: build additionally a u-boot binary used for nand boot
-#SPL_BINARY_colibri-vf50 = "u-boot.nand"
-#SPL_IMAGE_colibri-vf50 = "u-boot-${MACHINE}-${PV}-${PR}.nand"
-#SPL_SYMLINK_colibri-vf50 = "u-boot-${MACHINE}.nand"
-#do_compile_append_colibri-vf50() {
-# # keep boot-hsmmc
-# mv u-boot.${UBOOT_SUFFIX} u-boot-mmc.${UBOOT_SUFFIX}
-# oe_runmake colibri_vf50_nand_config
-# oe_runmake ${UBOOT_MAKE_TARGET}
-# mv u-boot.${UBOOT_SUFFIX} u-boot-nand.${UBOOT_SUFFIX}
-# mv u-boot-mmc.${UBOOT_SUFFIX} u-boot.${UBOOT_SUFFIX}
-#
-# # prepare the u-boot for nand
-# dd if=/dev/zero of=u-boot-pad bs=1024 count=1
-# cat u-boot-pad u-boot-nand.${UBOOT_SUFFIX} > ${SPL_BINARY}
-#}
-
-# colibri_vf50: build additionally a u-boot binary used for sd-card boot
-SPL_BINARY_colibri-vf50 = "u-boot.imx"
-SPL_IMAGE_colibri-vf50 = "u-boot-${MACHINE}-${PV}-${PR}.imx"
-SPL_SYMLINK_colibri-vf50 = "u-boot-${MACHINE}.imx"
-do_compile_append_colibri-vf50() {
+# colibri_vf: build additionally a u-boot binary used for sd-card boot
+SPL_BINARY_colibri-vf = "u-boot.imx"
+SPL_IMAGE_colibri-vf = "u-boot-${MACHINE}-${PV}-${PR}.imx"
+SPL_SYMLINK_colibri-vf = "u-boot-${MACHINE}.imx"
+do_compile_append_colibri-vf() {
oe_runmake colibri_vf50_sdboot_config
oe_runmake
}
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
index 540c924..d5eff6d 100644
--- a/recipes-kernel/linux/linux-toradex-vf_git.bb
+++ b/recipes-kernel/linux/linux-toradex-vf_git.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux.inc
LINUX_VERSION ?= "3.0.15"
-SRCREV_colibri-vf50 = "87af4ef6e63b55de3c34cd20e9ebb54b0e0ded05"
-PR_colibri-vf50 = "V2.1b1"
+SRCREV_colibri-vf = "fff8692e9818f930c0e40c3e1a631799fb78c13f"
+PR_colibri-vf = "V2.1b2"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
@@ -13,7 +13,7 @@ SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri_v
# SRC_URI += "file://a.patch "
-COMPATIBLE_MACHINE_colibri-vf50 = "colibri-vf50"
+COMPATIBLE_MACHINE_colibri-vf = "colibri-vf"
# Place changes to the defconfig here
config_script () {
@@ -21,10 +21,6 @@ config_script () {
# #sets CONFIG_TEGRA_CAMERA unconditionally to 'y'
# sed -i -e /CONFIG_TEGRA_CAMERA/d ${S}/.config
# echo "CONFIG_TEGRA_CAMERA=y" >> ${S}/.config
- sed -i -e /CONFIG_VFPv3/d ${S}/.config
- echo "CONFIG_VFPv3=y" >> ${S}/.config
- sed -i -e /CONFIG_NEON/d ${S}/.config
- echo "CONFIG_NEON=y" >> ${S}/.config
echo "dummy" > /dev/null
}
@@ -33,6 +29,9 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
+ #until we have the unified kernel
+ DEFCONFIG=colibri_vf50_defconfig
+
oe_runmake $DEFCONFIG
#maybe change some configuration
diff --git a/recipes-support/fbset/files/colibri-vf50/fb.modes b/recipes-support/fbset/files/colibri-vf/fb.modes
index ba902ce..ba902ce 100644
--- a/recipes-support/fbset/files/colibri-vf50/fb.modes
+++ b/recipes-support/fbset/files/colibri-vf/fb.modes