summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-07-11 18:43:15 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-01-04 13:40:32 +0100
commitef0b353dd1c7520896e0747fa3952e2e9e1abd56 (patch)
tree4273888c02da7c89adcca2b09b3b2c53e2ff9987
parent000346785a92c407a10eb474280793a932125759 (diff)
Revert "mesa: Remove parts provided by imx-gpu-viv v6"
This reverts commit 04e23f29eddd5691abed947a2e0dd364259248dc. This now lives in meta-freescale. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
deleted file mode 100644
index 74396ae..0000000
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ /dev/null
@@ -1,43 +0,0 @@
-PACKAGECONFIG_remove_imxgpu2d = "egl gles gbm"
-
-PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl gbm"
-PROVIDES_remove_imxgpu3d = "virtual/libgl"
-
-# FIXME: mesa should support 'x11-no-tls' option
-python () {
- overrides = d.getVar("OVERRIDES", True).split(":")
- if "imxgpu2d" not in overrides:
- return
-
- x11flag = d.getVarFlag("PACKAGECONFIG", "x11", False)
- d.setVarFlag("PACKAGECONFIG", "x11", x11flag.replace("--enable-glx-tls", "--enable-glx"))
-}
-
-# Enable Etnaviv support
-PACKAGECONFIG_append_use-mainline-bsp = " gallium"
-GALLIUMDRIVERS_append_use-mainline-bsp = ",etnaviv,imx"
-
-BACKEND = \
- "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
- 'fb', d), d)}"
-
-# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
-do_install_append_imxgpu3d () {
- rm -f ${D}${libdir}/libGL.* \
- ${D}${includedir}/GL/gl.h \
- ${D}${includedir}/GL/glext.h \
- ${D}${includedir}/GL/glx.h \
- ${D}${includedir}/GL/glxext.h
- if [ "${BACKEND}" = "x11" ]; then
- rm -f ${D}${libdir}/pkgconfig/gl.pc
- fi
-}
-
-do_install_append_imxgpu2d () {
- rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc
-}
-
-do_install_append_imxgpu2d () {
- rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc
-}