summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2022-10-10 14:29:30 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-10-14 13:55:14 +0200
commit28b3f43ce152a2a90908e5eb469e318ff65c0f3e (patch)
tree38858ff605dc45afea0c98d9b80a036f2b348d30
parent457264ed1381ac09ca0980340881360b433553f2 (diff)
colibri-imx6ull-emmc/verdin-imx8mm/verdin-imx8mp/imx-boot: fix overrides
Turns out that somehow we still have some old override syntax stuff laying around! Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit 70bc6c6d11a0d1c693fa63bdcbcafee8cd793bdf)
-rw-r--r--conf/machine/colibri-imx6ull-emmc.conf2
-rw-r--r--conf/machine/verdin-imx8mm.conf6
-rw-r--r--conf/machine/verdin-imx8mp.conf6
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend4
4 files changed, 9 insertions, 9 deletions
diff --git a/conf/machine/colibri-imx6ull-emmc.conf b/conf/machine/colibri-imx6ull-emmc.conf
index 64db068..2e57f53 100644
--- a/conf/machine/colibri-imx6ull-emmc.conf
+++ b/conf/machine/colibri-imx6ull-emmc.conf
@@ -28,7 +28,7 @@ KERNEL_DEVICETREE:use-nxp-bsp = " \
KERNEL_IMAGETYPE = "zImage"
# The kernel lives in its own ubi volume.
-RRECOMMENDS_${KERNEL_PACKAGE_NAME}-base = ""
+RRECOMMENDS:${KERNEL_PACKAGE_NAME}-base = ""
IMX_DEFAULT_BOOTLOADER = "u-boot-toradex"
PREFERRED_PROVIDER_u-boot-default-script ?= "u-boot-script-toradex"
diff --git a/conf/machine/verdin-imx8mm.conf b/conf/machine/verdin-imx8mm.conf
index 781f5c0..7665ec0 100644
--- a/conf/machine/verdin-imx8mm.conf
+++ b/conf/machine/verdin-imx8mm.conf
@@ -31,9 +31,9 @@ UBOOT_CONFIG ??= "sd"
UBOOT_CONFIG[sd] = "verdin-imx8mm_defconfig,sdcard"
SPL_BINARY = "spl/u-boot-spl.bin"
-UBOOT_DTB_LOADADDRESS_mx8mm = "0x50200000"
-UBOOT_DTBO_LOADADDRESS_mx8mm = "0x50240000"
-UBOOT_ENTRYPOINT_mx8mm = "0x48200000"
+UBOOT_DTB_LOADADDRESS:mx8mm-generic-bsp = "0x50200000"
+UBOOT_DTBO_LOADADDRESS:mx8mm-generic-bsp = "0x50240000"
+UBOOT_ENTRYPOINT:mx8mm-generic-bsp = "0x48200000"
UBOOT_RD_LOADADDRESS = "0x50300000"
# Set u-boot DTB
diff --git a/conf/machine/verdin-imx8mp.conf b/conf/machine/verdin-imx8mp.conf
index e18c9ef..25368e5 100644
--- a/conf/machine/verdin-imx8mp.conf
+++ b/conf/machine/verdin-imx8mp.conf
@@ -31,9 +31,9 @@ UBOOT_CONFIG ??= "sd"
UBOOT_CONFIG[sd] = "verdin-imx8mp_defconfig,sdcard"
SPL_BINARY = "spl/u-boot-spl.bin"
-UBOOT_DTB_LOADADDRESS_mx8mp = "0x50200000"
-UBOOT_DTBO_LOADADDRESS_mx8mp = "0x50240000"
-UBOOT_ENTRYPOINT_mx8mp = "0x48200000"
+UBOOT_DTB_LOADADDRESS:mx8mp-generic-bsp = "0x50200000"
+UBOOT_DTBO_LOADADDRESS:mx8mp-generic-bsp = "0x50240000"
+UBOOT_ENTRYPOINT:mx8mp-generic-bsp = "0x48200000"
UBOOT_RD_LOADADDRESS = "0x50300000"
# Set u-boot DTB
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index 02546ad..23096f1 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -1,9 +1,9 @@
# Create symbolic link rather than copying mkimage_uboot
-compile_mx8m:prepend() {
+compile:mx8m-generic-bsp:prepend() {
rm -rf ${BOOT_STAGING}/mkimage_uboot
# export LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE}:$LD_LIBRARY_PATH
}
-compile_mx8m:append() {
+compile:mx8m-generic-bsp:append() {
rm -rf ${BOOT_STAGING}/mkimage_uboot
ln -frs ${STAGING_DIR_NATIVE}/${bindir}/mkimage ${BOOT_STAGING}/mkimage_uboot
}