summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefano Viola <stefano.viola@toradex.com>2022-06-24 11:19:20 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-07-01 22:06:20 +0200
commita054c6edb4308892a25d3af1516de8b1c3b5a5df (patch)
tree8ee4ecab91cfa88f9ba04644b8f612e9b25f0b45
parent87a91be73929c8f998f30c70f3a0f0a14e17b127 (diff)
u-boot-toradex: deploy u-boot-with-spl.imx for imx6
The u-boot-with-spl.imx binary (if available), will be copied in the DEPLOYDIR for MACHINE colibri-imx6 and apalis-imx6. This binary is needed to implement bootloader software update where having only one binary instead of SPL + u-boot.bin simplifies things especially in the cloud platform side. Signed-off-by: Stefano Viola <stefano.viola@toradex.com> (cherry picked from commit e3461a0b4d163ab5dff0d8368028586a260ddbed)
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.07.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
index 7a72a34..b4a87a5 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
@@ -31,6 +31,14 @@ nand_padding () {
dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
}
+deploy_uboot_with_spl () {
+ for config in ${UBOOT_MACHINE}; do
+ if [ -f "${B}/${config}/u-boot-with-spl.imx" ]; then
+ install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
+ fi
+ done
+}
+
do_compile:append:colibri-imx6ull () {
nand_padding
}
@@ -42,3 +50,11 @@ do_compile:append:colibri-imx7 () {
do_compile:append:colibri-vf () {
nand_padding
}
+
+do_deploy:append:colibri-imx6 () {
+ deploy_uboot_with_spl
+}
+
+do_deploy:append:apalis-imx6 () {
+ deploy_uboot_with_spl
+}