summaryrefslogtreecommitdiff
path: root/backports
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-01-28 13:32:37 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-01-30 19:31:32 +0100
commitd95ca34f34d08273aedc6e0cc3265d9240671ee0 (patch)
treecdc9499a7170ae01704b74c7266c286e08db81a0 /backports
parent5ae5cd5489d538372d97a6c4df0f57fde8de6dae (diff)
imx-dpu-g2d: update to 6.4.3.p1.0
NXP release imx_5.4.70_2.3.0. This package uses EULA v17 October 2020. Related-to: ELB-3327 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'backports')
-rw-r--r--backports/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.8.12.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/backports/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.8.12.bb b/backports/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.8.12.bb
new file mode 100644
index 0000000..c407fb4
--- /dev/null
+++ b/backports/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.8.12.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2016 Freescale Semiconductor
+# Copyright 2017-2019 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
+PROVIDES += "virtual/libg2d"
+
+SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
+SRC_URI[md5sum] = "18a4119f1f7b83a09f60381e5403bbab"
+SRC_URI[sha256sum] = "ba7e219b3cee32e0ac305685de21c67f30e0e5a1a89b5ec441ae6b8484b3f964"
+
+inherit fsl-eula-unpack
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
+ cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
+ cp -r ${S}/gpu-demos/opt ${D}
+}
+
+FILES_${PN} = "${libdir}/libg2d* /opt"
+FILES_${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
+INSANE_SKIP_${PN} += "ldflags"
+
+RDEPENDS_${PN} = "libgal-imx libdrm"
+
+# This is required to provide support for VPU Amphion HEVC tile format
+# From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99):
+# VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx.
+RDEPENDS_${PN} += "libopencl-imx"
+
+COMPATIBLE_MACHINE = "(imxdpu)"