summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-08-09 16:27:11 +0200
committerStefan Agner <stefan.agner@toradex.com>2016-09-28 11:14:43 -0700
commita98a2b72be32a089d07b6613941bb371a4c2803c (patch)
tree225531ed328dd97ab1710be3c106ea497c1fa5cd /conf
parent0ca0991f67f34072100685f37909b8db887c2bef (diff)
add layer.conf
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf18
1 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..3b1666b
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,18 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "toradex-nxp-layer"
+BBFILE_PATTERN_toradex-nxp-layer = "^${LAYERDIR}/"
+BBFILE_PRIORITY_toradex-nxp-layer = "90"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"