summaryrefslogtreecommitdiff
path: root/recipes-bsp/imx-atf
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2019-07-16 21:03:45 +0800
committerMing Liu <ming.liu@toradex.int>2019-07-18 11:46:20 +0000
commitf417eb3eded48c902f35322ac75b252ead5bc3dd (patch)
tree4d07086e2adb388b4501ef86ec1b17140c4a8ec4 /recipes-bsp/imx-atf
parent785d8feebe9bd7afc392a5d18a3f2e1c86a66b59 (diff)
imx-atf: override PLATFORM to imx8qxp for mx8qxp machine
This is needed to build imx-atf version 1.5. Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-atf')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index 535bb98..c48fb6b 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -2,9 +2,11 @@ PV = "1.5.0+git${SRCPV}"
SRCBRANCH = "imx_4.14.78_1.0.0_ga"
SRCREV = "d6451cc1e162eff89b03dd63e86d55b9baa8885b"
+PLATFORM_mx8qxp = "imx8qxp"
+
# imx-atf 1.5 uses bl31-imx8qxp.bin, 2.0 will use bl31-imx8qx.bin for a
# platform specific filename. Provide both for now, so that the user of
# the file need not care.
do_deploy_append_mx8qxp () {
install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-imx8qx.bin
-} \ No newline at end of file
+}