summaryrefslogtreecommitdiff
path: root/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-28 13:52:34 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-29 20:58:21 +0200
commit614a6a418eaad6869a6d19a5d441b0240861729f (patch)
tree191e6c371d30eb02ae15952c74fc8dc3f479ee23 /recipes-bsp/imx-mkimage/imx-boot_%.bbappend
parentec10bdb7b7462ddb4987efc0f4995c89b9090c97 (diff)
imx-boot: use the right dcd for apalis-imx8a0
The Apalis iMX8 QM V1.0A require a specific DCD. Inject that DCD file and change the Makefile to actually use it. (The DCD for B0 silicon integrated in the SCFW and irrelevant here) Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_%.bbappend')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend11
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index d568a38..74555fa 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -1,15 +1,22 @@
SRCBRANCH = "imx_4.14.78_1.0.0_ga"
SRCREV = "2cf091c075ea1950afa22a56e224dc4e448db542"
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI += " \
+ file://0001-add-board-support-for-DCD-memory-timings.patch \
+ file://0002-add-memory-timings-for-Apalis-iMX8.patch \
+"
+
# Cope with i.MX8 / i.MX8X A0 Silicon DCD name
-DCD_NAME_mx8qma0 = "imx8qm_dcd.cfg.tmp"
+DCD_NAME_mx8qma0 = "imx8qm_*dcd.cfg.tmp"
+export DCD_BOARD = "apalis-imx8"
DCD_COPY = "false"
DCD_COPY_mx8qma0 = "true"
deploy_mx8() {
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
if [ "${DCD_COPY}" = "true" ]; then
- install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
fi
install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}