summaryrefslogtreecommitdiff
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-12-14 14:41:40 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2018-12-18 17:26:32 +0100
commitde504a1923f09ea25e0beb1ccc375e113e207067 (patch)
tree480746e66c17d34cb1b0a0d9396160bcc469ae0f /recipes-bsp/imx-vpu
parent5a6074a815b83a443751bf97c910be71774a4404 (diff)
imx-vpu: Update version from 5.4.37 to 5.4.38
Pulled from 1594c64aa5d51a0c97835f6548215fb0b48e0a34 on meta-freescale/master. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
new file mode 100644
index 0000000..f0c9d5a
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2013-2018 O.S. Systems Software LTDA.
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017 NXP
+
+DESCRIPTION = "Freescale VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
+
+DEPENDS = "virtual/kernel"
+
+PROVIDES = "virtual/imxvpu"
+
+PE = "1"
+
+SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
+
+SRC_URI[md5sum] = "521d5f839829f8d1f2a6a0e60270243e"
+SRC_URI[sha256sum] = "34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f"
+
+inherit fsl-eula-unpack
+
+PLATFORM_mx6 = "IMX6Q"
+
+do_compile () {
+ INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
+
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
+}
+
+do_install () {
+ oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6)"