summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-09 22:22:01 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 19:47:15 +0200
commitddcdce6443b4926840265ad39139d8e485ab579e (patch)
treeb7235af4372b522dec00ca3a295b1ecb635f9ea4 /recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb
parente605d184fa537450ab496f9d304740696499fef7 (diff)
u-boot-toradex: update to 2019.07
Update to a 2019.07 based U-Boot. Use the openembedded master recipes for u-boot_2019.07 as a base. This makes the u-boot recipe in recipes-bsp/u-boot-mainline/ obsolete, delete it. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb')
-rw-r--r--recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb b/recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb
deleted file mode 100644
index b5ce568..0000000
--- a/recipes-bsp/u-boot-mainline/u-boot-fw-utils_2019.07plus.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-require u-boot-common.inc
-
-SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-DEPENDS += "mtd-utils"
-
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
-
-inherit uboot-config
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake envtools
-}
-
-do_install () {
- install -d ${D}${base_sbindir}
- install -d ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
-}
-
-do_install_class-cross () {
- install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
-}
-
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-BBCLASSEXTEND = "cross"