summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot-mainline
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-14 19:22:44 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-14 19:34:35 +0200
commit384ad550e552b0d4d2907284b1fc904ad97acf12 (patch)
treef7b158488a9fc633d536001e31dab69f7b43e2f7 /recipes-bsp/u-boot-mainline
parent15badd4aac13483a4d6148af141cd54b2e1c2ebe (diff)
u-boot: fix mainline not providing a nand target
Our downstream U-Boot provides a u-boot-nand.imx target prepending the binary with a 1k block for easier flashing while the mainline U-Boot does not. Mimic the behaviour in a do_compile_append. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot-mainline')
-rw-r--r--recipes-bsp/u-boot-mainline/u-boot_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot-mainline/u-boot_%.bbappend b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
new file mode 100644
index 0000000..996f4e9
--- /dev/null
+++ b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
@@ -0,0 +1,14 @@
+# U-Boot is flashed 1k into a NAND block, create a binary which prepends
+# U-boot with 1k of zeros to ease flashing
+
+nand_padding () {
+ dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx > u-boot-nand.imx
+}
+
+do_compile_append_colibri-imx6ull () {
+ nand_padding
+}
+
+do_compile_append_colibri-imx7 () {
+ nand_padding
+}