summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/files/default-gcc.patch
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-11-20 12:51:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 16:15:32 +0100
commit2951149d43f771768f0b2823665b4887b7e20b4b (patch)
treee527d0daef0cae3913902a1aee5c1e46cc15f799 /recipes-bsp/u-boot/files/default-gcc.patch
parentf11b9f99d48bd6db2283e376131861f4dff3ddc1 (diff)
u-boot-toradex-fw-utils: rework after move to 3rdparty
The recipe got moved to meta-freescale-3rdparty. Rework additional settings into a bbappend. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/files/default-gcc.patch')
-rw-r--r--recipes-bsp/u-boot/files/default-gcc.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-bsp/u-boot/files/default-gcc.patch b/recipes-bsp/u-boot/files/default-gcc.patch
deleted file mode 100644
index 04184df..0000000
--- a/recipes-bsp/u-boot/files/default-gcc.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-OE needs to be able to change the default compiler. If we pass in HOSTCC
-through the make command, it overwrites not only this setting but also the
-setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which
-breaks the build.
-
-We therefore use override to ensure the value of HOSTCC is overwritten when
-needed.
-
-RP: Updated the patch to the version being submitted to upstream u-boot
-
-Upstream-Status: Submitted [emailed to Masahiro Yamada for discussion]
-RP 2017/3/11
-
-Index: git/tools/Makefile
-===================================================================
---- git.orig/tools/Makefile
-+++ git/tools/Makefile
-@@ -262,7 +262,7 @@ $(LICENSE_H): $(obj)/bin2header $(srctre
- subdir- += env
-
- ifneq ($(CROSS_BUILD_TOOLS),)
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- quiet_cmd_crosstools_strip = STRIP $^
- cmd_crosstools_strip = $(STRIP) $^; touch $@
-Index: git/tools/env/Makefile
-===================================================================
---- git.orig/tools/env/Makefile
-+++ git/tools/env/Makefile
-@@ -8,7 +8,7 @@
- # fw_printenv is supposed to run on the target system, which means it should be
- # built with cross tools. Although it may look weird, we only replace "HOSTCC"
- # with "CC" here for the maximum code reuse of scripts/Makefile.host.
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- # Compile for a hosted environment on the target
- HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \