summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/files
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-11-20 12:51:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 16:15:32 +0100
commit2951149d43f771768f0b2823665b4887b7e20b4b (patch)
treee527d0daef0cae3913902a1aee5c1e46cc15f799 /recipes-bsp/u-boot/files
parentf11b9f99d48bd6db2283e376131861f4dff3ddc1 (diff)
u-boot-toradex-fw-utils: rework after move to 3rdparty
The recipe got moved to meta-freescale-3rdparty. Rework additional settings into a bbappend. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/files')
-rw-r--r--recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/files/colibri-imx7/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/files/default-gcc.patch39
-rw-r--r--recipes-bsp/u-boot/files/fw_env.config22
-rw-r--r--recipes-bsp/u-boot/files/mx6/fw_env.config15
-rw-r--r--recipes-bsp/u-boot/files/vf/fw_env.config11
6 files changed, 0 insertions, 109 deletions
diff --git a/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config b/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config
deleted file mode 100644
index 30b8b90..0000000
--- a/recipes-bsp/u-boot/files/colibri-imx6ull/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri iMX7
-/dev/mtd3 0x00000000 0x00020000 0x20000 4
-
diff --git a/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config b/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config
deleted file mode 100644
index 30b8b90..0000000
--- a/recipes-bsp/u-boot/files/colibri-imx7/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri iMX7
-/dev/mtd3 0x00000000 0x00020000 0x20000 4
-
diff --git a/recipes-bsp/u-boot/files/default-gcc.patch b/recipes-bsp/u-boot/files/default-gcc.patch
deleted file mode 100644
index 04184df..0000000
--- a/recipes-bsp/u-boot/files/default-gcc.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-OE needs to be able to change the default compiler. If we pass in HOSTCC
-through the make command, it overwrites not only this setting but also the
-setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which
-breaks the build.
-
-We therefore use override to ensure the value of HOSTCC is overwritten when
-needed.
-
-RP: Updated the patch to the version being submitted to upstream u-boot
-
-Upstream-Status: Submitted [emailed to Masahiro Yamada for discussion]
-RP 2017/3/11
-
-Index: git/tools/Makefile
-===================================================================
---- git.orig/tools/Makefile
-+++ git/tools/Makefile
-@@ -262,7 +262,7 @@ $(LICENSE_H): $(obj)/bin2header $(srctre
- subdir- += env
-
- ifneq ($(CROSS_BUILD_TOOLS),)
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- quiet_cmd_crosstools_strip = STRIP $^
- cmd_crosstools_strip = $(STRIP) $^; touch $@
-Index: git/tools/env/Makefile
-===================================================================
---- git.orig/tools/env/Makefile
-+++ git/tools/env/Makefile
-@@ -8,7 +8,7 @@
- # fw_printenv is supposed to run on the target system, which means it should be
- # built with cross tools. Although it may look weird, we only replace "HOSTCC"
- # with "CC" here for the maximum code reuse of scripts/Makefile.host.
--HOSTCC = $(CC)
-+override HOSTCC = $(CC)
-
- # Compile for a hosted environment on the target
- HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
diff --git a/recipes-bsp/u-boot/files/fw_env.config b/recipes-bsp/u-boot/files/fw_env.config
deleted file mode 100644
index e054ccb..0000000
--- a/recipes-bsp/u-boot/files/fw_env.config
+++ /dev/null
@@ -1,22 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# NOR example
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-#/dev/mtd1 0x0000 0x4000 0x4000
-#/dev/mtd2 0x0000 0x4000 0x4000
-
-# MTD SPI-dataflash example
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-#/dev/mtd5 0x4200 0x4200
-#/dev/mtd6 0x4200 0x4200
-
-# NAND example
-#/dev/mtd0 0x4000 0x4000 0x20000 2
-
-# Block device example
-#/dev/mmcblk0 0xc0000 0x20000
diff --git a/recipes-bsp/u-boot/files/mx6/fw_env.config b/recipes-bsp/u-boot/files/mx6/fw_env.config
deleted file mode 100644
index 731d874..0000000
--- a/recipes-bsp/u-boot/files/mx6/fw_env.config
+++ /dev/null
@@ -1,15 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Device offset must be prefixed with 0x to be parsed as a hexadecimal value.
-# On a block device a negative offset is treated as a backwards offset from the
-# end of the device/partition, rather than a forwards offset from the start.
-
-# Colibri iMX6/Apalis iMX6
-# U-Boot environment is stored at the end of the first eMMC boot partition
-# hence use a negative value. The environment is just in front of the config
-# block which occupies the last sector (hence -0x200)
-
-# Block device name Device offset Env. size
-/dev/mmcblk0boot0 -0x2200 0x2000
-
diff --git a/recipes-bsp/u-boot/files/vf/fw_env.config b/recipes-bsp/u-boot/files/vf/fw_env.config
deleted file mode 100644
index c1581ea..0000000
--- a/recipes-bsp/u-boot/files/vf/fw_env.config
+++ /dev/null
@@ -1,11 +0,0 @@
-# Configuration file for fw_(printenv/setenv) utility.
-# Up to two entries are valid, in this case the redundant
-# environment sector is assumed present.
-# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
-# Futhermore, if the Flash sector size is ommitted, this value is assumed to
-# be the same as the Environment size, which is valid for NOR and SPI-dataflash
-
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-# Colibri VF61
-/dev/mtd2 0x00000000 0x00020000 0x20000 4
-