summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-11-20 12:51:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 16:15:32 +0100
commit2951149d43f771768f0b2823665b4887b7e20b4b (patch)
treee527d0daef0cae3913902a1aee5c1e46cc15f799 /recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
parentf11b9f99d48bd6db2283e376131861f4dff3ddc1 (diff)
u-boot-toradex-fw-utils: rework after move to 3rdparty
The recipe got moved to meta-freescale-3rdparty. Rework additional settings into a bbappend. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
new file mode 100644
index 0000000..00bc9de
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+include conf/tdx_version.conf
+
+SRCREV = "02735f400478c6e9afc432fda1149abef630657c"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
+SRC_URI += "file://fw_unlock_mmc.sh"
+
+PV = "2016.11+git${SRCPV}"
+LOCALVERSION ?= "-${TDX_VER_ITEM}"
+
+S = "${WORKDIR}/git"
+
+install_unlock_emmc() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
+do_install_append_apalis-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx7-emmc() {
+ install_unlock_emmc
+}
+