summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-05-06 12:07:31 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-23 22:14:32 +0100
commitc75fd6cad03715ea248ad363719eee8741ae046a (patch)
treed52f6242066d4efc698595fad64f2ad7a81de7b1 /recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
parent0b7f72d7947313ce1db0a7c0bb77c5a4a132e6e8 (diff)
u-boot: upstream 2016.11
Upstream U-Boot 2016.11 for all NXP based modules to meta-freescale-3rdparty. Remove the files for the older 2015.04 based U-Boot. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2016.11.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
deleted file mode 100644
index 215bed7..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
+++ /dev/null
@@ -1,55 +0,0 @@
-require recipes-bsp/u-boot/u-boot-toradex.inc
-
-DESCRIPTION = "U-Boot for NXP based Toradex Computer on Modules"
-PV = "2016.11"
-PR = "${TDX_VER_INT}+gitr${SRCPV}"
-
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-
-SRCREV = "52259cf22a165c0721bb26c723c0dc5e2659eaa7"
-SRCBRANCH = "2016.11-toradex"
-COMPATIBLE_MACHINE = "(mx6|mx7|vf)"
-
-
-# Hack around building two U-Boot configurations, one with, one without SPL
-# if using UBOOT_CONFIG to build more than one configuration, the current code in
-# u-boot.inc assumes all are either with or without SPL.
-do_compile_append_mx6() {
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- touch ${B}/${config}/${SPL_BINARY}
- done
- fi
-}
-do_deploy_append_mx6() {
- # if SPL is zero sized file, remove all deployed artefacts
- if [ -n "${SPL_BINARY}" ]
- then
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- if [ ! -s ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR} ]
- then
- rm -f ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR}
- rm -f ${DEPLOYDIR}/${SPL_BINARYNAME}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}
- else
- ln -sf ${SPL_IMAGE}-${type}-${PV}-${PR} ${SPL_BINARYNAME}
- fi
- fi
- done
- unset j
- done
- unset i
- fi
- fi
-}
-
-DEPENDS_append = " dtc-native"