summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-07-18 22:55:19 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-08-04 11:12:26 +0200
commitcf5528f0507f3f5f847f16c0e2b59edc04057e99 (patch)
tree61f55d932c28ad780263cadba39ba871c842b8c2 /recipes-bsp/u-boot
parentc7628509199baf4c277892eb6f5432b99c967d4d (diff)
u-boot-fw-utils: add config für colibri-vf and apalis-imx6
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/files/fw_env.config22
-rw-r--r--recipes-bsp/u-boot/files/mx6/fw_env.config23
-rw-r--r--recipes-bsp/u-boot/files/vf/fw_env.config11
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb28
4 files changed, 70 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/files/fw_env.config b/recipes-bsp/u-boot/files/fw_env.config
new file mode 100644
index 0000000..c9b9f6a
--- /dev/null
+++ b/recipes-bsp/u-boot/files/fw_env.config
@@ -0,0 +1,22 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd1 0x0000 0x4000 0x4000
+/dev/mtd2 0x0000 0x4000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
diff --git a/recipes-bsp/u-boot/files/mx6/fw_env.config b/recipes-bsp/u-boot/files/mx6/fw_env.config
new file mode 100644
index 0000000..0da5083
--- /dev/null
+++ b/recipes-bsp/u-boot/files/mx6/fw_env.config
@@ -0,0 +1,23 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd1 0x0000 0x4000 0x4000
+#/dev/mtd2 0x0000 0x4000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+# Apalis iMX6
+/dev/mmcblk2 0x80000 0x2000
diff --git a/recipes-bsp/u-boot/files/vf/fw_env.config b/recipes-bsp/u-boot/files/vf/fw_env.config
new file mode 100644
index 0000000..fad5e93
--- /dev/null
+++ b/recipes-bsp/u-boot/files/vf/fw_env.config
@@ -0,0 +1,11 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+# Colibri VF61
+/dev/mtd2 0x00000000 0x00020000 0x20000 1
+
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index e4f88b1..256862c 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -1,7 +1,5 @@
DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
@@ -13,30 +11,32 @@ DEFAULT_PREFERENCE_apalis-imx6 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
-SRCREV_apalis-imx6 = "214db18e6c38454e1c4d22b472dda07db062f976"
-SRCBRANCH_colibri-vf = "colibri_vf"
-SRCBRANCH_apalis-imx6 = "toradex_imx6"
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+SRCREV_colibri-vf = "0b4191106b32ca91afa759f3620fc470cf61d7c2"
+SRCREV_apalis-imx6 = "0b4191106b32ca91afa759f3620fc470cf61d7c2"
+SRCBRANCH_colibri-vf = "2014.04-toradex"
+SRCBRANCH_apalis-imx6 = "2014.04-toradex"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
+ file://fw_env.config \
+"
PV = "${PR}+gitr${SRCREV}"
PR = "r0"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
-
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
inherit uboot-config
do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
}
do_install () {
- install -d ${D}${base_sbindir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -d ${D}${base_sbindir} ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv_unstripped ${D}${base_sbindir}/fw_printenv
+ ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
PACKAGE_ARCH = "${MACHINE_ARCH}"