summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-01-28 10:53:32 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-01-30 19:31:32 +0100
commit5eed1ed77e0dd047034ef12fb7d5ad90f746629b (patch)
treec1852bd7d73388a9195e666da8c75adbda29eb64 /recipes-bsp
parent78e03021e778780d782042ac9835ba5920013bad (diff)
imx-boot: cope with existing work directory
bitbake fails if the mkimage_uboot symlink in the work directory already exists. Delete it before recrating it. | ERROR: imx-boot-1.0-r0 do_compile: Execution of '..temp/run.do_compile.43961' failed with exit code 1: | cp: '...recipe-sysroot-native//usr/bin/mkimage' and '...git/iMX8M/mkimage_uboot' are the same file Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index d137231..bd97840 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -1,5 +1,8 @@
+# Create symbolic link rather than copying mkimage_uboot
+compile_mx8m_prepend() {
+ rm -rf ${BOOT_STAGING}/mkimage_uboot
+}
compile_mx8m_append() {
- # Create symbolic link rather than copying mkimage_uboot
rm -rf ${BOOT_STAGING}/mkimage_uboot
lnr ${STAGING_DIR_NATIVE}/${bindir}/mkimage ${BOOT_STAGING}/mkimage_uboot
}