summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2019-07-15 18:31:01 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2019-07-15 18:31:01 +0200
commit3a5210bb8614f26478cb96780c6d9045c8d77db7 (patch)
tree10941ce5ccacd5cf3bfc5c6435004516c9801539 /recipes-bsp
parentedf854b5f77b61d60e57d7ae72c343aa395544c9 (diff)
u-boot-toradex: re-add 2016.11
Re-add U-Boot Toradex 2016.11 as Tezi (and TorizonCore) may still depend on it. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend31
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend11
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
new file mode 100644
index 0000000..9d6d46d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRCREV = "83a53c1c0c6fd813bd655b4f88fd07bf798e11d7"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
+SRC_URI += "file://fw_unlock_mmc.sh"
+
+PV = "2016.11+git${SRCPV}"
+LOCALVERSION ?= "-${TDX_VER_ITEM}"
+
+S = "${WORKDIR}/git"
+
+install_unlock_emmc() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
+do_install_append_apalis-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx7-emmc() {
+ install_unlock_emmc
+}
+
+# defaults
+TDX_VER_ITEM ??= "0"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
new file mode 100644
index 0000000..5ad16f2
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
@@ -0,0 +1,11 @@
+require recipes-bsp/u-boot/u-boot-toradex-env.inc
+
+LOCALVERSION = "-${TDX_VER_ITEM}"
+
+SRCREV = "83a53c1c0c6fd813bd655b4f88fd07bf798e11d7"
+SRCBRANCH = "2016.11-toradex"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
+
+# defaults
+TDX_VER_ITEM ??= "0"