summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-09-03 15:05:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2017-10-03 17:07:14 +0200
commita92467dcb408031ec839fa63c29391155c320be5 (patch)
tree627cce96951e1febadaa33d851125cf29a0c9cfb /recipes-bsp
parentfd600b08d5a72d46e9fa1bae6c8fc435aa653b10 (diff)
u-boot-toradex: fix mixed spl/standard workaround
The workaround for U-Boot being compiled with and without SPL assumes a certain directory structure. For machines only building one U-Boot, the workaround may introduce and error. Fix this. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
index 1a5ec54..ad57c83 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
@@ -13,9 +13,12 @@ COMPATIBLE_MACHINE = "(mx6|mx7|vf)"
# if using UBOOT_CONFIG to build more than one configuration, the current code in
# u-boot.inc assumes all are either with or without SPL.
do_compile_append_mx6() {
- for config in ${UBOOT_MACHINE}; do
- touch ${B}/${config}/${SPL_BINARY}
- done
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ touch ${B}/${config}/${SPL_BINARY}
+ done
+ fi
}
do_deploy_append_mx6() {
# if SPL is zero sized file, remove all deployed artefacts