summaryrefslogtreecommitdiff
path: root/recipes-devtools/imx-loader/imx-loader_git.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-03-26 10:42:25 +0100
committerStefan Agner <stefan.agner@toradex.com>2014-03-26 10:46:45 +0100
commite93046da8550d65ef7aea9c7e0756f2fdf8bbe5b (patch)
treedf121ff1287e1b2bc24f85ea5b86002b9bbae80e /recipes-devtools/imx-loader/imx-loader_git.bb
parentce32e98222dc128f79edd9789728dab5b28e2b72 (diff)
imx-loader: add UART/USB loader for i.MX/Vybrid SoCs
imx-loader allows to load data directly into memory through the Serial Download Protocol (SDP). This package contains two binaries, the imx_usb and the imx_uart utility for the two supported hardware links. Configuration are available from the /etc/imx-loader.d/ directory.
Diffstat (limited to 'recipes-devtools/imx-loader/imx-loader_git.bb')
-rw-r--r--recipes-devtools/imx-loader/imx-loader_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/imx-loader/imx-loader_git.bb b/recipes-devtools/imx-loader/imx-loader_git.bb
new file mode 100644
index 0000000..1a59e35
--- /dev/null
+++ b/recipes-devtools/imx-loader/imx-loader_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "USB/UART loader for i.MX51/53/6x and Vybrid"
+SECTION = "base"
+HOMEPAGE = "https://github.com/boundarydevices/imx_usb_loader"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "libusb1-native"
+
+SRCREV = "5d1d28fc99c33766eea8e8735ed7b912c54eab1e"
+SRC_URI = "git://github.com/toradex/imx_loader.git;protocol=git;branch=uart_loader"
+
+S = "${WORKDIR}/git/"
+
+PR = "r1"
+
+#we want mkfs.ubifs binary to run on a 32 bit architecture, on x86-64 this requires the 32 bit compatibility libs
+#EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR -m32' 'BUILDDIR=${S}'"
+
+BBCLASSEXTEND = "native"
+
+do_install () {
+ oe_runmake install
+}