summaryrefslogtreecommitdiff
path: root/recipes-fsl
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-11-17 17:57:02 +0100
committerStefan Agner <stefan.agner@toradex.com>2017-01-09 15:05:59 -0800
commit61c1fa334f71a425cde997f1f9cc189d03f92c00 (patch)
treee3c96f6ee2c26b7a3d722dcb1ac022e6cd94b9b9 /recipes-fsl
parent9b60acdb4817fe64bf62b837f1ffeb03a8d07d35 (diff)
packagegroup-fsl-gpu-libs: added to only deploy the libraries
This provides an alternative to packagegroup-fsl-tools-gpu which installs examples and tools which pull in also the libraries but blows up image size. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb b/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb
new file mode 100644
index 0000000..94ff260
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb
@@ -0,0 +1,19 @@
+# Copyright (C) 2016 Toradex AG
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Deploys Vivante GPU libraries, even if no package RDEPENDS on them"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = " \
+ libgl-mx6 \
+ libgles-mx6 \
+ libgles2-mx6 \
+ libopenvg-mx6 \
+ libvdk-mx6 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'xserver-xorg-extension-viv-autohdmi', \
+ '', d), d)} \
+"