summaryrefslogtreecommitdiff
path: root/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-12-07 11:30:56 -0600
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-23 22:15:42 +0100
commit6cf4769de230d8c902b3419f50ee26abca028688 (patch)
treec3193e348be74d739834027e53395844744ffb75 /recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
parent272a7cb554098ddc3939862df8e19e74d055aeea (diff)
imx-gpu-g2d: Move imx-gpu-g2d out of imx-gpu-viv v6
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb')
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
new file mode 100644
index 0000000..8be05f9
--- /dev/null
+++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
@@ -0,0 +1,36 @@
+# Copyright (C) 2016 Freescale Semiconductor
+# Copyright 2017 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "GPU G2D library and apps for imx6"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671"
+
+PROVIDES += "virtual/libg2d"
+
+SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+inherit fsl-eula-unpack
+
+SRC_URI[md5sum] = "64720dda9b96fd7af5be7e2c654ab72a"
+SRC_URI[sha256sum] = "070a95aa9942bd67e8ba4012962df74143bffb9998301ac097dab5e1437000d8"
+
+do_install () {
+
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+
+ cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
+ cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
+ cp -r ${S}/gpu-demos/opt ${D}
+}
+
+RDEPENDS_${PN} = "libgal-imx"
+
+FILES_${PN} = "${libdir}/libg2d* /opt"
+FILES_${PN}-dev = "${includedir}"
+INSANE_SKIP_${PN} = "ldflags"
+
+COMPATIBLE_MACHINE = "(mx6|mx7ulp)"