summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland/weston_9.0.0.imx.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-02-04 21:51:07 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-02-22 18:34:26 +0100
commit31b6041d525f36c20f20e8f9b9d06fd515fe9d1a (patch)
treedeb50d5aac48fe3fcfe018bd2fbdf8cad2732f29 /recipes-graphics/wayland/weston_9.0.0.imx.bbappend
parent40ea7dd9bf213d2e822d4a1b2ecc68a0cc24e1a7 (diff)
weston: imx: fix use with fbdev/pixman
If the imx fork is used on a i.MX 6ULL stopping weston may result in a segfault due to using already freed memory. Make sure to only call pixman_renderer_output_destroy() once and harden pixman_renderer_output_destroy() to not segfault should it be called twice. Related-to: ELB-3532 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 942c1d04fb1c57e0698620adc03fbd476c8fbe93)
Diffstat (limited to 'recipes-graphics/wayland/weston_9.0.0.imx.bbappend')
-rw-r--r--recipes-graphics/wayland/weston_9.0.0.imx.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bbappend b/recipes-graphics/wayland/weston_9.0.0.imx.bbappend
index d5609a3..d4c3eea 100644
--- a/recipes-graphics/wayland/weston_9.0.0.imx.bbappend
+++ b/recipes-graphics/wayland/weston_9.0.0.imx.bbappend
@@ -4,3 +4,9 @@
PACKAGECONFIG_remove = "wayland x11"
PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcursor"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/weston/:"
+SRC_URI_append = " \
+ file://0001-libweston-backend-fbdev-fbdev.c-don-t-destroy-output.patch \
+ file://0002-libweston-pixman-renderer.c-zero-freed-pointer.patch \
+"