summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-03-31 16:09:40 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:36 +0200
commit8f956760a93f3e4cb330a377715887ed55771db1 (patch)
tree3a9b147ffdc3dcb28c300f75ef39a6b98e8eb7b7 /recipes-graphics
parentd36ced39cbe01d8baf68ca8801273f49f54aebf7 (diff)
libdrm: update patch to be compatible with thumb2
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch36
-rw-r--r--recipes-graphics/drm/libdrm_2.4.46.bbappend1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch b/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch
new file mode 100644
index 0000000..a463d03
--- /dev/null
+++ b/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch
@@ -0,0 +1,36 @@
+Add ARM support into xf86arm.h. This provides support for Xorg interface.
+Without this the vivante samples will hang during close requiring a reboot
+
+Upstream-Status: Pending
+
+Signed-off-by: Lauren Post <lauren.post@freescale.com>
+Signed-off-by: Evan Kotara <evan.kotara@freescale.com>
+
+diff --git a/xf86drm.h b/xf86drm.h
+--- a/xf86drm.h
++++ b/xf86drm.h
+@@ -455,6 +455,24 @@ do { register unsigned int __old __asm("o0"); \
+ : "cr0", "memory"); \
+ } while (0)
+
++#elif defined(__arm__)
++ #undef DRM_DEV_MODE
++ #define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH)
++
++ #define DRM_CAS(lock,old,new,__ret) \
++ do { \
++ __asm__ __volatile__ ( \
++ "1: ldrex %0, [%1]\n" \
++ " teq %0, %2\n" \
++ " it eq\n" \
++ " strexeq %0, %3, [%1]\n" \
++ " it ne\n" \
++ " movne %0, #1\n" \
++ : "=&r" (__ret) \
++ : "r" (lock), "r" (old), "r" (new) \
++ : "cc","memory"); \
++ } while (0)
++
+ #endif /* architecture */
+ #endif /* __GNUC__ >= 2 */
+
diff --git a/recipes-graphics/drm/libdrm_2.4.46.bbappend b/recipes-graphics/drm/libdrm_2.4.46.bbappend
new file mode 100644
index 0000000..72d991c
--- /dev/null
+++ b/recipes-graphics/drm/libdrm_2.4.46.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"