summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-12-14 15:00:12 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2018-12-18 17:26:32 +0100
commit7a5b32e66f4682b5d94588ce2a6125f2e81b76ce (patch)
tree2cf15c211eeb5a539c1b9dec26c12d228e3a8fe6 /recipes-graphics
parent70b1c5ceec15cb3c92813de9e275c4a66ca61b09 (diff)
xf86-video-imx-vivante: Upgrade from 6.2.2.p0 to 6.2.4.p1.8
Pulled from 6c1f35fdd5a762a3376c314dd36c564858d20cdb on meta-freescale/master. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi (renamed from recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi)0
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.2.4.p1.8.bb (renamed from recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc)38
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb9
3 files changed, 15 insertions, 32 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi b/recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi
index 8c16a1d..8c16a1d 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi
+++ b/recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc b/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.2.4.p1.8.bb
index c16da67..670ade6 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
+++ b/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.2.4.p1.8.bb
@@ -1,5 +1,6 @@
-# Copyright (C) 2012-2015 Freescale Semiconductor
-# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
+# Copyright (C) 2012-2016 Freescale Semiconductor
+# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
+# Copyright 2017-2018 NXP
# Released under the MIT license (see COPYING.MIT for the terms)
require recipes-graphics/xorg-driver/xorg-driver-video.inc
@@ -8,10 +9,12 @@ PE = "3"
inherit autotools-brokensep update-rc.d pkgconfig
-DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv virtual/libg2d pixman"
+DEPENDS += "virtual/xserver virtual/libx11 libgal-imx imx-gpu-viv virtual/libg2d pixman"
LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3"
+SRCREV = "b765c3ffc0dcc4246afa659aa0d59f78a6736b08"
+SRCBRANCH = "imx_exa_viv6_g2d"
SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \
file://rc.autohdmi"
@@ -21,36 +24,25 @@ INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
INITSCRIPT_NAME = "rc.autohdmi"
INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
-EXTRA_OEMAKE += "prefix=${D}/usr \
+EXTRA_OEMAKE += "prefix=${exec_prefix} \
sysroot=${STAGING_DIR_TARGET} \
- LFLAGS="${LDFLAGS}" \
+ SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
BUSID_HAS_NUMBER=1 \
BUILD_IN_YOCTO=1 \
XSERVER_GREATER_THAN_13=1"
-
-CFLAGS += "-I${STAGING_INCDIR}/xorg \
- -I${STAGING_INCDIR}/drm \
- -I../../DRI_1.10.4/src"
+TARGET_CC_ARCH += "${LDFLAGS}"
PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
-# FIXME: The Freescale provided Makefile has hardcodec include paths
-# and this does not work in case prefix is different than /usr,
-# sed it.
-do_configure_prepend () {
- sed -i 's,$(sysroot)/usr/include,${STAGING_INCDIR},g' \
- ${S}EXA/src/makefile.linux
-}
-
do_install_append () {
- install -d ${D}${includedir}
- cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
- cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
+ install -d ${D}${includedir}
+ cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
+ cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
- install -d ${D}/${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
- find ${D}${includedir} -type f -exec chmod 660 {} \;
+ find ${D}${includedir} -type f -exec chmod 660 {} \;
}
RDEPENDS_${PN} += "libvivante-dri-imx \
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb
deleted file mode 100644
index 5514962..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-# Copyright (C) 2012-2016 Freescale Semiconductor
-# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
-# Copyright 2017 NXP
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require xf86-video-imxfb-vivante.inc
-
-SRCBRANCH = "nxp/imx_4.9.11_1.0.0_ga"
-SRCREV = "07ef065dfe09f1c05a1a188c371577faa3677a17"