summaryrefslogtreecommitdiff
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-12-14 14:56:45 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2018-12-18 17:26:32 +0100
commit7d80b610729801d7158c00ebda6b5d3ce4bd9b2e (patch)
treebf7b92ba51777462696accdf647d5c6d69b4d14a /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
parent3268f7cd76f0ad10648d34e133a976e6be97e5ba (diff)
kernel-module-imx-gpu-viv: Upgrade version from 6.2.2.p0 to 6.2.4.p1.8
Pulled from f1e26d9de04bc80aeff8e8e31e2f0862f0556419 on meta-freescale/master. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch326
1 files changed, 326 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
new file mode 100644
index 0000000..63f408c
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
@@ -0,0 +1,326 @@
+Index: git/Makefile
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/Makefile 2017-06-27 12:07:11.931698672 -0500
+@@ -0,0 +1,17 @@
++obj-m := galcore.o
++
++SRC := $(shell pwd)
++
++all:
++ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)/src AQROOT=${PWD}/src
++ cp $(SRC)/src/Module.symvers $(PWD)
++ cp $(SRC)/src/modules.order $(PWD)
++
++modules_install:
++ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)/src modules_install
++
++clean:
++ find . -name '*.o' -delete
++ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
++ rm -f Module.markers Module.symvers modules.order
++ rm -rf .tmp_versions Modules.symvers
+Index: git/src/hal/kernel/arch/makefile.linux
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/src/hal/kernel/arch/makefile.linux 2017-06-27 11:44:06.004826232 -0500
+@@ -0,0 +1,91 @@
++##############################################################################
++#
++# The MIT License (MIT)
++#
++# Copyright (c) 2014 - 2017 Vivante Corporation
++#
++# Permission is hereby granted, free of charge, to any person obtaining a
++# copy of this software and associated documentation files (the "Software"),
++# to deal in the Software without restriction, including without limitation
++# the rights to use, copy, modify, merge, publish, distribute, sublicense,
++# and/or sell copies of the Software, and to permit persons to whom the
++# Software is furnished to do so, subject to the following conditions:
++#
++# The above copyright notice and this permission notice shall be included in
++# all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
++# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++# DEALINGS IN THE SOFTWARE.
++#
++##############################################################################
++#
++# The GPL License (GPL)
++#
++# Copyright (C) 2014 - 2017 Vivante Corporation
++#
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License
++# as published by the Free Software Foundation; either version 2
++# of the License, or (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software Foundation,
++# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
++#
++##############################################################################
++#
++# Note: This software is released under dual MIT and GPL licenses. A
++# recipient may use this file under the terms of either the MIT license or
++# GPL License. If you wish to use only one license not the other, you can
++# indicate your decision by deleting one of the above license notices in your
++# version of this file.
++#
++##############################################################################
++
++
++#
++# Linux build file for architecture dependent kernel HAL layer.
++#
++
++################################################################################
++# Include common definitions.
++
++include $(AQROOT)/makefile.linux.def
++
++################################################################################
++# Define a shortcut for the main target.
++
++STATIC = 1
++TARGET_NAME = libhalarchkernel.a
++
++################################################################################
++# Supply additional include directories.
++
++INCLUDE += -I$(AQROOT)/hal/kernel/inc
++INCLUDE += -I$(AQROOT)/hal/kernel/inc
++INCLUDE += -I$(AQROOT)/hal/kernel
++INCLUDE += -I$(AQROOT)/hal/kernel/arch
++ifeq ($(VIVANTE_ENABLE_VG),1)
++INCLUDE += -I$(AQROOT)/hal/kernel/archvg
++endif
++
++CFLAGS += $(INCLUDE) -Werror -ansi
++
++
++################################################################################
++# Describe object files.
++
++OBJECTS = $(OBJ_DIR)/gc_hal_kernel_context.o \
++ $(OBJ_DIR)/gc_hal_kernel_hardware.o
++
++include $(AQROOT)/common.target
+Index: git/src/hal/kernel/archvg/makefile.linux
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/src/hal/kernel/archvg/makefile.linux 2017-06-27 11:44:06.004826232 -0500
+@@ -0,0 +1,91 @@
++##############################################################################
++#
++# The MIT License (MIT)
++#
++# Copyright (c) 2014 - 2017 Vivante Corporation
++#
++# Permission is hereby granted, free of charge, to any person obtaining a
++# copy of this software and associated documentation files (the "Software"),
++# to deal in the Software without restriction, including without limitation
++# the rights to use, copy, modify, merge, publish, distribute, sublicense,
++# and/or sell copies of the Software, and to permit persons to whom the
++# Software is furnished to do so, subject to the following conditions:
++#
++# The above copyright notice and this permission notice shall be included in
++# all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
++# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++# DEALINGS IN THE SOFTWARE.
++#
++##############################################################################
++#
++# The GPL License (GPL)
++#
++# Copyright (C) 2014 - 2017 Vivante Corporation
++#
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License
++# as published by the Free Software Foundation; either version 2
++# of the License, or (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software Foundation,
++# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
++#
++##############################################################################
++#
++# Note: This software is released under dual MIT and GPL licenses. A
++# recipient may use this file under the terms of either the MIT license or
++# GPL License. If you wish to use only one license not the other, you can
++# indicate your decision by deleting one of the above license notices in your
++# version of this file.
++#
++##############################################################################
++
++
++#
++# Linux build file for architecture dependent kernel HAL layer.
++#
++
++################################################################################
++# Include common definitions.
++
++include $(AQROOT)/makefile.linux.def
++
++################################################################################
++# Define a shortcut for the main target.
++
++STATIC = 1
++
++TARGET_NAME = libhalarchkernelvg.a
++
++################################################################################
++# Supply additional include directories.
++
++INCLUDE += -I$(AQROOT)/hal/inc
++INCLUDE += -I$(AQROOT)/hal/user
++INCLUDE += -I$(AQROOT)/hal/kernel
++INCLUDE += -I$(AQROOT)/hal/kernel/arch
++ifeq ($(VIVANTE_ENABLE_VG), 1)
++INCLUDE += -I$(AQROOT)/hal/kernel/archvg
++endif
++
++CFLAGS += $(INCLUDE) -Werror -ansi
++
++################################################################################
++# Describe object files.
++
++OBJECTS = $(OBJ_DIR)/gc_hal_kernel_hardware_vg.o \
++ $(OBJ_DIR)/gc_hal_kernel_hardware_command_vg.o
++
++include $(AQROOT)/common.target
+Index: git/src/hal/kernel/makefile.linux
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/src/hal/kernel/makefile.linux 2017-06-27 11:44:06.004826232 -0500
+@@ -0,0 +1,107 @@
++##############################################################################
++#
++# The MIT License (MIT)
++#
++# Copyright (c) 2014 - 2017 Vivante Corporation
++#
++# Permission is hereby granted, free of charge, to any person obtaining a
++# copy of this software and associated documentation files (the "Software"),
++# to deal in the Software without restriction, including without limitation
++# the rights to use, copy, modify, merge, publish, distribute, sublicense,
++# and/or sell copies of the Software, and to permit persons to whom the
++# Software is furnished to do so, subject to the following conditions:
++#
++# The above copyright notice and this permission notice shall be included in
++# all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
++# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
++# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
++# DEALINGS IN THE SOFTWARE.
++#
++##############################################################################
++#
++# The GPL License (GPL)
++#
++# Copyright (C) 2014 - 2017 Vivante Corporation
++#
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License
++# as published by the Free Software Foundation; either version 2
++# of the License, or (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software Foundation,
++# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
++#
++##############################################################################
++#
++# Note: This software is released under dual MIT and GPL licenses. A
++# recipient may use this file under the terms of either the MIT license or
++# GPL License. If you wish to use only one license not the other, you can
++# indicate your decision by deleting one of the above license notices in your
++# version of this file.
++#
++##############################################################################
++
++
++#
++# Linux build file for architecture dependent kernel HAL layer.
++#
++#
++
++
++################################################################################
++# Include common definitions.
++
++include $(AQROOT)/makefile.linux.def
++
++################################################################################
++# Define a shortcut for the main target.
++
++STATIC = 1
++TARGET_NAME = libhalkernel.a
++
++################################################################################
++# Supply additional include directories.
++
++INCLUDE += -I$(AQROOT)/hal/kernel/inc
++INCLUDE += -I$(AQROOT)/hal/kernel/inc
++INCLUDE += -I$(AQROOT)/hal/kernel/arch
++INCLUDE += -I$(AQROOT)/hal/kernel
++ifeq ($(VIVANTE_ENABLE_VG),1)
++INCLUDE += -I$(AQROOT)/hal/kernel/archvg
++endif
++INCLUDE += -I$(AQROOT)/hal/os/linux/kernel
++CFLAGS += $(INCLUDE) -Werror -ansi
++
++
++################################################################################
++# Describe object files.
++
++OBJECTS = $(OBJ_DIR)/gc_hal_kernel_command.o \
++ $(OBJ_DIR)/gc_hal_kernel_db.o \
++ $(OBJ_DIR)/gc_hal_kernel_debug.o \
++ $(OBJ_DIR)/gc_hal_kernel_event.o \
++ $(OBJ_DIR)/gc_hal_kernel_heap.o \
++ $(OBJ_DIR)/gc_hal_kernel.o \
++ $(OBJ_DIR)/gc_hal_kernel_mmu.o \
++ $(OBJ_DIR)/gc_hal_kernel_video_memory.o
++
++ifeq ($(VIVANTE_ENABLE_VG),1)
++OBJECTS += \
++ $(OBJ_DIR)/gc_hal_kernel_command_vg.o \
++ $(OBJ_DIR)/gc_hal_kernel_interrupt_vg.o \
++ $(OBJ_DIR)/gc_hal_kernel_mmu_vg.o \
++ $(OBJ_DIR)/gc_hal_kernel_vg.o
++endif
++
++include $(AQROOT)/common.target