summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-12-07 18:18:19 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-12-15 15:48:59 +0100
commitc599a05c6bd45afcbc8eb1ff561fbb8b721ffda6 (patch)
tree03b4de6c6d88523ccb60290f29630ece25b2580a /recipes-kernel/linux
parent73da1ee5127a0823c14eea579423878c083da2dc (diff)
linux-toradex_4.1: update to latest revision
Update to latest revision which contains a SPI bugfix and the latest upstream stable release v4.1.15. Also synchronize the VF defconfig. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-toradex-4.1/defconfig14
-rw-r--r--recipes-kernel/linux/linux-toradex_4.1.bbappend4
2 files changed, 15 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-toradex-4.1/defconfig b/recipes-kernel/linux/linux-toradex-4.1/defconfig
index 550c32a..45f2421 100644
--- a/recipes-kernel/linux/linux-toradex-4.1/defconfig
+++ b/recipes-kernel/linux/linux-toradex-4.1/defconfig
@@ -51,6 +51,7 @@ CONFIG_IP_ADVANCED_ROUTER=y
CONFIG_IP_MULTIPLE_TABLES=y
CONFIG_IP_PNP=y
CONFIG_IP_PNP_DHCP=y
+CONFIG_NET_IPGRE_DEMUX=m
# CONFIG_INET_XFRM_MODE_TRANSPORT is not set
# CONFIG_INET_XFRM_MODE_TUNNEL is not set
# CONFIG_INET_XFRM_MODE_BEET is not set
@@ -74,6 +75,7 @@ CONFIG_IP_NF_NAT=y
CONFIG_IP_NF_TARGET_MASQUERADE=y
CONFIG_IP6_NF_IPTABLES=y
CONFIG_NF_TABLES_BRIDGE=y
+CONFIG_L2TP=m
CONFIG_BRIDGE=y
# CONFIG_BRIDGE_IGMP_SNOOPING is not set
CONFIG_BRIDGE_VLAN_FILTERING=y
@@ -126,6 +128,12 @@ CONFIG_NETDEVICES=y
# CONFIG_NET_VENDOR_VIA is not set
# CONFIG_NET_VENDOR_WIZNET is not set
CONFIG_MICREL_PHY=y
+CONFIG_PPP=m
+CONFIG_PPP_DEFLATE=m
+CONFIG_PPP_MPPE=m
+CONFIG_PPTP=m
+CONFIG_PPPOL2TP=m
+CONFIG_PPP_ASYNC=m
CONFIG_USB_NET_DRIVERS=m
CONFIG_USB_USBNET=m
# CONFIG_USB_NET_CDC_NCM is not set
@@ -205,10 +213,14 @@ CONFIG_SND=y
# CONFIG_SND_USB is not set
CONFIG_SND_SOC=y
CONFIG_SND_SOC_FSL_SAI=y
-CONFIG_SND_SOC_FSL_SAI_WM9712=y
CONFIG_SND_IMX_SOC=y
+CONFIG_SND_SOC_FSL_SAI_WM9712=y
+CONFIG_HIDRAW=y
+CONFIG_HID_MULTITOUCH=m
+CONFIG_USB_HIDDEV=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_ACM=m
CONFIG_USB_STORAGE=y
CONFIG_USB_CHIPIDEA=y
CONFIG_USB_CHIPIDEA_UDC=y
diff --git a/recipes-kernel/linux/linux-toradex_4.1.bbappend b/recipes-kernel/linux/linux-toradex_4.1.bbappend
index 2cb0e53..33f7ce6 100644
--- a/recipes-kernel/linux/linux-toradex_4.1.bbappend
+++ b/recipes-kernel/linux/linux-toradex_4.1.bbappend
@@ -3,5 +3,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-toradex-4.1:"
# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
-LOCALVERSION = "-v2.5b2"
-SRCREV = "559570ccdc6555d2228a4e4e9e589e3145d7c2e4"
+LOCALVERSION = "-v2.5b3"
+SRCREV = "e6d111cd909551cec5902358db1e25dcaa8c86bb"