summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-10-19 14:07:02 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-11-27 11:28:51 +0100
commit4a567ef806c5491e59f8e5590bfb064f3b3327d0 (patch)
treea69cc8a316f47d0a370f61ffcaba7e36e0372969 /recipes-kernel/linux
parent45c33b79a734d016dddb997c1895b53202286f23 (diff)
kernel recipes: automatically update to latest -next through override
This can be used e.g. for a CI setup to do nightly builds of latest and greatest. To use HEAD of xxx-next instead of the pinned version one would add in local.conf: MACHINEOVERRIDES =. "use-head-next:" Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb2
-rw-r--r--recipes-kernel/linux/linux-toradex-rt_4.4.bb2
-rw-r--r--recipes-kernel/linux/linux-toradex_4.1-2.0.x.bbappend2
-rw-r--r--recipes-kernel/linux/linux-toradex_4.4.bbappend2
4 files changed, 8 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb b/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
index b9cecc3..f320be7 100644
--- a/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
+++ b/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
@@ -26,6 +26,8 @@ PR = "${TDX_VER_INT}-rt"
SRCBRANCH = "toradex_4.1-2.0.x-imx"
SRCREV = "82f0f4f012a646a735d6b44de77b7c9d0712c714"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_4.1-2.0.x-imx-next"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(mx7|mx6)"
diff --git a/recipes-kernel/linux/linux-toradex-rt_4.4.bb b/recipes-kernel/linux/linux-toradex-rt_4.4.bb
index 5b95642..a32e69d 100644
--- a/recipes-kernel/linux/linux-toradex-rt_4.4.bb
+++ b/recipes-kernel/linux/linux-toradex-rt_4.4.bb
@@ -18,5 +18,7 @@ PR = "${TDX_VER_INT}"
SRCREV = "c1d5fe2d54551b95b812143d94d8168da2220dd8"
SRCBRANCH = "toradex_vf_4.4"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_vf_4.4-next"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(vf)"
diff --git a/recipes-kernel/linux/linux-toradex_4.1-2.0.x.bbappend b/recipes-kernel/linux/linux-toradex_4.1-2.0.x.bbappend
index 608f1a5..0ec6ad6 100644
--- a/recipes-kernel/linux/linux-toradex_4.1-2.0.x.bbappend
+++ b/recipes-kernel/linux/linux-toradex_4.1-2.0.x.bbappend
@@ -6,3 +6,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-toradex-4.1-2.0.x:"
SRCREV = "b1555bfbf38818bc6fed8d921b55b7b207249c53"
SRCBRANCH = "toradex_4.1-2.0.x-imx"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_4.1-2.0.x-imx-next"
diff --git a/recipes-kernel/linux/linux-toradex_4.4.bbappend b/recipes-kernel/linux/linux-toradex_4.4.bbappend
index 5e40c2b..3f59137 100644
--- a/recipes-kernel/linux/linux-toradex_4.4.bbappend
+++ b/recipes-kernel/linux/linux-toradex_4.4.bbappend
@@ -7,3 +7,5 @@ PR = "${TDX_VER_INT}"
SRCREV = "e0f2806138a4eeb3c31abe0e0e767d0f6d9a13a3"
SRCBRANCH = "toradex_vf_4.4"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_vf_4.4-next"