summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-07-10 17:42:26 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-10-03 05:51:21 -0700
commit959f16c71c8aea4226de1cafb4796218106d7431 (patch)
tree416b5e22cc228f1f50b30b7f2909dcb26cd13fe4 /recipes-kernel
parent23a9de3af244629ac8c4acfd4cc0c926faacdee9 (diff)
linux-toradex-rt: 4.1-2.0.x, rt patch follow patchlevel update
Also include the patch from Julio Cruz which allows to use the external vivante kernel module from meta-freescale. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0001-cgroup-defs.h-add-missing-include.patch36
-rw-r--r--recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0004-export-swait-locked-functions.patch31
-rw-r--r--recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb11
3 files changed, 73 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0001-cgroup-defs.h-add-missing-include.patch b/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0001-cgroup-defs.h-add-missing-include.patch
new file mode 100644
index 0000000..4e50fac
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0001-cgroup-defs.h-add-missing-include.patch
@@ -0,0 +1,36 @@
+From 93f6cf15ca06a8de52c3179a6d55ce7a396f9757 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Mon, 10 Jul 2017 17:18:28 +0200
+Subject: [PATCH] cgroup-defs.h: add missing include
+
+fix compiletime error with our 4.1.41 derived kernel
+at 82f0f4f012a646a735d6b44de77b7c9d0712c714 and
+patch-4.1.40-rt48.patch.gz
+
+| CC arch/arm/kernel/asm-offsets.s
+| In file included from /build/krm/oe-core_2.7.3/build/tmp-glibc/work-shared/colibri-imx6/kernel-source/include/linux/sched.h:62:0,
+| from /build/krm/oe-core_2.7.3/build/tmp-glibc/work-shared/colibri-imx6/kernel-source/arch/arm/kernel/asm-offsets.c:14:
+| /build/krm/oe-core_2.7.3/build/tmp-glibc/work-shared/colibri-imx6/kernel-source/include/linux/cgroup-defs.h:128:21: error: field 'destroy_swork' has incomplete type
+| struct swork_event destroy_swork;
+| ^~~~~~~~~~~~~
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ include/linux/cgroup-defs.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/linux/cgroup-defs.h b/include/linux/cgroup-defs.h
+index 3fc3b8e..2538559 100644
+--- a/include/linux/cgroup-defs.h
++++ b/include/linux/cgroup-defs.h
+@@ -16,6 +16,7 @@
+ #include <linux/percpu-refcount.h>
+ #include <linux/percpu-rwsem.h>
+ #include <linux/workqueue.h>
++#include <linux/work-simple.h>
+
+ #ifdef CONFIG_CGROUPS
+
+--
+2.9.4
+
diff --git a/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0004-export-swait-locked-functions.patch b/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0004-export-swait-locked-functions.patch
new file mode 100644
index 0000000..1a616aa
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/0004-export-swait-locked-functions.patch
@@ -0,0 +1,31 @@
+From 2460dd985b0cf477f74396de92d1bc5df496abdc Mon Sep 17 00:00:00 2001
+From: Julio Cruz <jcsistemas2001@gmail.com>
+Date: Wed, 20 Jan 2016 19:26:44 +0800
+Subject: [PATCH] Export symbols for iMX-GPU-VIV module
+
+---
+ kernel/sched/wait-simple.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/kernel/sched/wait-simple.c b/kernel/sched/wait-simple.c
+index 7dfa86d..a3776ee 100644
+--- a/kernel/sched/wait-simple.c
++++ b/kernel/sched/wait-simple.c
+@@ -40,6 +40,7 @@ void swait_prepare_locked(struct swait_head *head, struct swaiter *w)
+ if (list_empty(&w->node))
+ __swait_enqueue(head, w);
+ }
++EXPORT_SYMBOL(swait_prepare_locked);
+
+ void swait_prepare(struct swait_head *head, struct swaiter *w, int state)
+ {
+@@ -58,6 +59,7 @@ void swait_finish_locked(struct swait_head *head, struct swaiter *w)
+ if (w->task)
+ __swait_dequeue(w);
+ }
++EXPORT_SYMBOL(swait_finish_locked);
+
+ void swait_finish(struct swait_head *head, struct swaiter *w)
+ {
+--
+2.1.0
diff --git a/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb b/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
index e2fde3d..b9cecc3 100644
--- a/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
+++ b/recipes-kernel/linux/linux-toradex-rt_4.1-2.0.x.bb
@@ -6,16 +6,17 @@ SUMMARY = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
-SRC_URI += "\
- https://www.kernel.org/pub/linux/kernel/projects/rt/4.1/older/patch-4.1.35-rt41.patch.gz;name=rt-patch \
+SRC_URI += " \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/4.1/older/patch-4.1.40-rt48.patch.gz;name=rt-patch \
+ file://0001-cgroup-defs.h-add-missing-include.patch \
file://0001-fix-build.patch \
file://0002-no-split-ptlocks.patch \
file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \
+ file://0004-export-swait-locked-functions.patch \
file://defconfig \
"
-
-SRC_URI[rt-patch.md5sum] = "375bb334b265898a94214c3199308298"
-SRC_URI[rt-patch.sha256sum] = "284a1bc0094df0a61e6dcb9996eceea6a3791ccba1e5763e36f251d0dfeecd32"
+SRC_URI[rt-patch.md5sum] = "085046ef6cecd45b7fcd9f2dfd9e7f1b"
+SRC_URI[rt-patch.sha256sum] = "3960999107c3a06eb9cc92c5b649a725b9d8f354a430cdf4f28305f6c8547d6a"
# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"