summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-06-21 12:24:20 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-06-21 19:45:56 +0200
commit7c80051e8c10787cdbb86bda5944f3a2d985bc56 (patch)
tree5571543674a979a111f8c002f5102510667a9268 /recipes-multimedia
parent7746413f5b7c19fa4364851cf6e13fcc89cff047 (diff)
multimedia: update to 4.14.98 2.0.0
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch167
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend4
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend6
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend8
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend8
8 files changed, 189 insertions, 19 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
index a7f5831..6cbf33b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bbappend
@@ -1,2 +1,3 @@
-SRCBRANCH = "MM_04.04.04_1811_L4.14.78_GA"
-SRCREV = "7e8a87fcbf5bd44b6982f6d15f2d28aa5f49a6be" \ No newline at end of file
+SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
+SRCREV = "0191521ba226904e4b2f84c38e5f6ae75169a18a"
+SRC_URI_remove ="file://0001-opencv-fix-build-for-opencv-3-4-2.patch" \ No newline at end of file
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
new file mode 100644
index 0000000..bcada34
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
@@ -0,0 +1,167 @@
+From 7022b87353a37b78bae7cf0106a4e47913bb5c97 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Thu, 5 Apr 2018 10:15:08 +0800
+Subject: [PATCH] Makefile.am: don't hardcode libtool name when running
+ introspection tools
+
+Upstream-Status: Pending [review on oe-core maillist]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+
+---
+ gst-libs/gst/allocators/Makefile.am | 2 +-
+ gst-libs/gst/app/Makefile.am | 2 +-
+ gst-libs/gst/audio/Makefile.am | 2 +-
+ gst-libs/gst/gl/Makefile.am | 2 +-
+ gst-libs/gst/pbutils/Makefile.am | 2 +-
+ gst-libs/gst/riff/Makefile.am | 2 +-
+ gst-libs/gst/rtp/Makefile.am | 2 +-
+ gst-libs/gst/rtsp/Makefile.am | 2 +-
+ gst-libs/gst/sdp/Makefile.am | 2 +-
+ gst-libs/gst/tag/Makefile.am | 2 +-
+ gst-libs/gst/video/Makefile.am | 2 +-
+ 11 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/gst-libs/gst/allocators/Makefile.am b/gst-libs/gst/allocators/Makefile.am
+index 1957d28..1ecc950 100644
+--- a/gst-libs/gst/allocators/Makefile.am
++++ b/gst-libs/gst/allocators/Makefile.am
+@@ -42,7 +42,7 @@ GstAllocators-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstallocators-@
+ --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \
+ --library=libgstallocators-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg-export gstreamer-allocators-@GST_API_VERSION@ \
+ --output $@ \
+diff --git a/gst-libs/gst/app/Makefile.am b/gst-libs/gst/app/Makefile.am
+index 52f6ad3..5bfd606 100644
+--- a/gst-libs/gst/app/Makefile.am
++++ b/gst-libs/gst/app/Makefile.am
+@@ -56,7 +56,7 @@ GstApp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstapp-@GST_API_VERSIO
+ --library=libgstapp-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg-export gstreamer-app-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/audio/Makefile.am b/gst-libs/gst/audio/Makefile.am
+index 2922245..7fb65f2 100644
+--- a/gst-libs/gst/audio/Makefile.am
++++ b/gst-libs/gst/audio/Makefile.am
+@@ -184,7 +184,7 @@ GstAudio-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstaudio-@GST_API_VE
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+ --include=GstTag-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg-export gstreamer-audio-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/gl/Makefile.am b/gst-libs/gst/gl/Makefile.am
+index 4e77e8c..3276d7f 100644
+--- a/gst-libs/gst/gl/Makefile.am
++++ b/gst-libs/gst/gl/Makefile.am
+@@ -193,7 +193,7 @@ GstGL-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstgl-@GST_API_VERSION@
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+ --include=GstVideo-@GST_API_VERSION@ \
+- --libtool="${LIBTOOL}" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg gstreamer-video-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/pbutils/Makefile.am b/gst-libs/gst/pbutils/Makefile.am
+index ae51993..35a6e44 100644
+--- a/gst-libs/gst/pbutils/Makefile.am
++++ b/gst-libs/gst/pbutils/Makefile.am
+@@ -103,7 +103,7 @@ GstPbutils-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstpbutils-@GST_AP
+ --include=GstTag-@GST_API_VERSION@ \
+ --include=GstVideo-@GST_API_VERSION@ \
+ --include=GstAudio-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-tag-@GST_API_VERSION@ \
+ --pkg gstreamer-video-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/riff/Makefile.am b/gst-libs/gst/riff/Makefile.am
+index fb53f06..e66ef4f 100644
+--- a/gst-libs/gst/riff/Makefile.am
++++ b/gst-libs/gst/riff/Makefile.am
+@@ -49,7 +49,7 @@ libgstriff_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS)
+ # --include=GstAudio-@GST_API_VERSION@ \
+ # --include=GstTag-@GST_API_VERSION@ \
+ # --include=Gst-@GST_API_VERSION@ \
+-# --libtool="$(top_builddir)/libtool" \
++# --libtool="$(LIBTOOL)" \
+ # --pkg gstreamer-@GST_API_VERSION@ \
+ # --pkg gstreamer-tag-@GST_API_VERSION@ \
+ # --pkg gstreamer-audio-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/rtp/Makefile.am b/gst-libs/gst/rtp/Makefile.am
+index a6f971d..77ebeeb 100644
+--- a/gst-libs/gst/rtp/Makefile.am
++++ b/gst-libs/gst/rtp/Makefile.am
+@@ -69,7 +69,7 @@ GstRtp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtp-@GST_API_VERSIO
+ --library=libgstrtp-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg-export gstreamer-rtp-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/rtsp/Makefile.am b/gst-libs/gst/rtsp/Makefile.am
+index ceb07f4..db9d0fd 100644
+--- a/gst-libs/gst/rtsp/Makefile.am
++++ b/gst-libs/gst/rtsp/Makefile.am
+@@ -76,7 +76,7 @@ GstRtsp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtsp-@GST_API_VERS
+ --include=Gio-2.0 \
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstSdp-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gio-2.0 \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-sdp-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/sdp/Makefile.am b/gst-libs/gst/sdp/Makefile.am
+index e197e9b..6e05cc7 100644
+--- a/gst-libs/gst/sdp/Makefile.am
++++ b/gst-libs/gst/sdp/Makefile.am
+@@ -34,7 +34,7 @@ GstSdp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstsdp-@GST_API_VERSIO
+ --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \
+ --library=libgstsdp-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg-export gstreamer-sdp-@GST_API_VERSION@ \
+ --output $@ \
+diff --git a/gst-libs/gst/tag/Makefile.am b/gst-libs/gst/tag/Makefile.am
+index 0247c33..c86515b 100644
+--- a/gst-libs/gst/tag/Makefile.am
++++ b/gst-libs/gst/tag/Makefile.am
+@@ -66,7 +66,7 @@ GstTag-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgsttag-@GST_API_VERSIO
+ --library=libgsttag-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg-export gstreamer-tag-@GST_API_VERSION@ \
+diff --git a/gst-libs/gst/video/Makefile.am b/gst-libs/gst/video/Makefile.am
+index 9fc1ccf..0f8455f 100644
+--- a/gst-libs/gst/video/Makefile.am
++++ b/gst-libs/gst/video/Makefile.am
+@@ -124,7 +124,7 @@ GstVideo-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstvideo-@GST_API_VE
+ --library=libgstvideo-@GST_API_VERSION@.la \
+ --include=Gst-@GST_API_VERSION@ \
+ --include=GstBase-@GST_API_VERSION@ \
+- --libtool="$(top_builddir)/libtool" \
++ --libtool="$(LIBTOOL)" \
+ --pkg gstreamer-@GST_API_VERSION@ \
+ --pkg gstreamer-base-@GST_API_VERSION@ \
+ --pkg-export gstreamer-video-@GST_API_VERSION@ \
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
index ff53fa3..337c5d5 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bbappend
@@ -1,2 +1,3 @@
-SRCBRANCH = "MM_04.04.04_1811_L4.14.78_GA"
-SRCREV = "318a9477159d6b162e480faf29f56153b27fb6a7"
+FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-plugins-base:"
+SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
+SRCREV = "f62f8ab685e549eefaecdb1e700239a5a408fcad"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
index d454a61..9a888c5 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.imx.bbappend
@@ -1,2 +1,3 @@
-SRCBRANCH = "MM_04.04.04_1811_L4.14.78_GA"
-SRCREV = "cec0ef39784a3acfd2b442d107f054c6ab10181e"
+SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
+SRCREV = "a31aabb7581d3f491cd31889d44479bb0f34990b"
+
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend
index 656e89c..6df7d19 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bbappend
@@ -1,2 +1,2 @@
-SRCBRANCH = "MM_04.04.04_1811_L4.14.78_GA"
-SRCREV = "f4e127a5e9a1eb977e023532d6636d939c8ccbc8"
+SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
+SRCREV = "d42548da09724ad8cc1aa4f1944607920be2f4c0"
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend
index 4badc17..e0ec1ba 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bbappend
@@ -1,3 +1,3 @@
-PV = "4.4.4"
-SRCBRANCH = "MM_04.04.04_1811_L4.14.78_GA"
-SRCREV = "79cf42955b5100cd1a3b2ea2647ceb7cfa50fffb"
+PV = "4.4.5"
+SRCBRANCH = "MM_04.04.05_1902_L4.14.98_GA"
+SRCREV = "0c5f48b3aee473d8c8f3e853eb2078f054caa4d2"
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend
index e0f99f0..83306d2 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend
+++ b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bbappend
@@ -1,4 +1,4 @@
-PV = "4.4.4"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6dfb32a488e5fd6bae52fbf6c7ebb086"
-SRC_URI[md5sum] = "181182985c0b7443bf1aad7cd3e52127"
-SRC_URI[sha256sum] = "cb31c1e05c81a3c03dffbc1d5fa552146133999d53ea8129971fa3954ade52cb"
+PV = "4.4.5"
+LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
+SRC_URI[md5sum] = "e17258161c84530097f6f9d5d46e6c26"
+SRC_URI[sha256sum] = "b53eeada02ab09c8f5216348c667f8d8edef0c585e4b2f738e8b18955ad710b4"
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend
index c60805a..bd4b0d2 100644
--- a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend
+++ b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bbappend
@@ -1,4 +1,4 @@
-PV = "4.4.4"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6dfb32a488e5fd6bae52fbf6c7ebb086"
-SRC_URI[md5sum] = "455f9f07ecf3c87510c547068a59c1b0"
-SRC_URI[sha256sum] = "bb273dfc3baae9bc8c4ba579a67bfed69e8f8289860f88e7f996ec59259a6305"
+PV = "4.4.5"
+LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
+SRC_URI[md5sum] = "7fa7b0fa1682cae71c3a163da866f676"
+SRC_URI[sha256sum] = "de86b57b429c0e6ed6b6842e5af1ec4d7b9d2074234769de6ba2edf04c967acd"