summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
index 1a5ec54..ad57c83 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb
@@ -13,9 +13,12 @@ COMPATIBLE_MACHINE = "(mx6|mx7|vf)"
# if using UBOOT_CONFIG to build more than one configuration, the current code in
# u-boot.inc assumes all are either with or without SPL.
do_compile_append_mx6() {
- for config in ${UBOOT_MACHINE}; do
- touch ${B}/${config}/${SPL_BINARY}
- done
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ touch ${B}/${config}/${SPL_BINARY}
+ done
+ fi
}
do_deploy_append_mx6() {
# if SPL is zero sized file, remove all deployed artefacts