summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/colibri-imx6ull.conf2
-rw-r--r--conf/machine/include/colibri-imx7.inc1
-rw-r--r--recipes-bsp/u-boot-mainline/u-boot_%.bbappend14
3 files changed, 16 insertions, 1 deletions
diff --git a/conf/machine/colibri-imx6ull.conf b/conf/machine/colibri-imx6ull.conf
index e7f103b..b339093 100644
--- a/conf/machine/colibri-imx6ull.conf
+++ b/conf/machine/colibri-imx6ull.conf
@@ -21,7 +21,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
PREFERRED_PROVIDER_u-boot ?= "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-toradex"
UBOOT_BINARY = "u-boot-nand.imx"
-UBOOT_MAKE_TARGET = "u-boot-nand.imx"
+UBOOT_MAKE_TARGET = "u-boot.imx"
UBOOT_MACHINE ?= "colibri-imx6ull_defconfig"
IMAGE_FSTYPES += "wic.gz tar.xz"
diff --git a/conf/machine/include/colibri-imx7.inc b/conf/machine/include/colibri-imx7.inc
index 654f0fa..dcd8048 100644
--- a/conf/machine/include/colibri-imx7.inc
+++ b/conf/machine/include/colibri-imx7.inc
@@ -9,3 +9,4 @@ TORADEX_FLASH_TYPE = "rawnand"
MACHINE_FIRMWARE_remove = "firmware-imx-epdc"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
+UBOOT_MAKE_TARGET_colibri-imx7 = "u-boot.imx" \ No newline at end of file
diff --git a/recipes-bsp/u-boot-mainline/u-boot_%.bbappend b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
new file mode 100644
index 0000000..996f4e9
--- /dev/null
+++ b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
@@ -0,0 +1,14 @@
+# U-Boot is flashed 1k into a NAND block, create a binary which prepends
+# U-boot with 1k of zeros to ease flashing
+
+nand_padding () {
+ dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx > u-boot-nand.imx
+}
+
+do_compile_append_colibri-imx6ull () {
+ nand_padding
+}
+
+do_compile_append_colibri-imx7 () {
+ nand_padding
+}