summaryrefslogtreecommitdiff
path: root/backports
diff options
context:
space:
mode:
Diffstat (limited to 'backports')
-rw-r--r--backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb b/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb
new file mode 100644
index 0000000..2b02823
--- /dev/null
+++ b/backports/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.7.bb
@@ -0,0 +1,29 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright (C) 2017-2020 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Freescale Multimedia VPU wrapper"
+LICENSE = "Proprietary"
+SECTION = "multimedia"
+LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
+
+DEPENDS = "virtual/imxvpu"
+DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
+
+SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
+
+SRCBRANCH = "MM_04.05.07_2011_L5.4.70"
+SRCREV = "ccaf10a0dae7c0d7d204bd64282598bc0e3bd661"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ # FIXME: Drop examples for now
+ rm -r ${D}${datadir}
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(imxvpu)"