summaryrefslogtreecommitdiff
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf14
1 files changed, 10 insertions, 4 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 3b1666b..eec2324 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,9 +1,8 @@
-# We have a conf and classes directory, add to BBPATH
+# We have a conf and classes directory, append to BBPATH
BBPATH .= ":${LAYERDIR}"
-# We have a recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "toradex-nxp-layer"
BBFILE_PATTERN_toradex-nxp-layer = "^${LAYERDIR}/"
@@ -16,3 +15,10 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
# Add layer-specific bb files too
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+
+LAYERDEPENDS_toradex-nxp-layer = " \
+ core \
+ freescale-layer \
+ fsl-arm-extra \
+ toradex-bsp-common-layer \
+"