summaryrefslogtreecommitdiff
path: root/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_%.bbappend')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend19
1 files changed, 2 insertions, 17 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index 74555fa..9b3fd36 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -1,23 +1,8 @@
-SRCBRANCH = "imx_4.14.78_1.0.0_ga"
-SRCREV = "2cf091c075ea1950afa22a56e224dc4e448db542"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += " \
- file://0001-add-board-support-for-DCD-memory-timings.patch \
- file://0002-add-memory-timings-for-Apalis-iMX8.patch \
-"
-
-# Cope with i.MX8 / i.MX8X A0 Silicon DCD name
-DCD_NAME_mx8qma0 = "imx8qm_*dcd.cfg.tmp"
-export DCD_BOARD = "apalis-imx8"
-DCD_COPY = "false"
-DCD_COPY_mx8qma0 = "true"
+SRCBRANCH = "imx_4.14.98_2.0.0_ga"
+SRCREV = "dd0234001713623c79be92b60fa88bc07b07f24f"
deploy_mx8() {
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- if [ "${DCD_COPY}" = "true" ]; then
- install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- fi
install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
}