summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot-mainline
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot-mainline')
-rw-r--r--recipes-bsp/u-boot-mainline/u-boot_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot-mainline/u-boot_%.bbappend b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
new file mode 100644
index 0000000..996f4e9
--- /dev/null
+++ b/recipes-bsp/u-boot-mainline/u-boot_%.bbappend
@@ -0,0 +1,14 @@
+# U-Boot is flashed 1k into a NAND block, create a binary which prepends
+# U-boot with 1k of zeros to ease flashing
+
+nand_padding () {
+ dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx > u-boot-nand.imx
+}
+
+do_compile_append_colibri-imx6ull () {
+ nand_padding
+}
+
+do_compile_append_colibri-imx7 () {
+ nand_padding
+}