summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index e4f88b1..256862c 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -1,7 +1,5 @@
DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
@@ -13,30 +11,32 @@ DEFAULT_PREFERENCE_apalis-imx6 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
-SRCREV_apalis-imx6 = "214db18e6c38454e1c4d22b472dda07db062f976"
-SRCBRANCH_colibri-vf = "colibri_vf"
-SRCBRANCH_apalis-imx6 = "toradex_imx6"
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+SRCREV_colibri-vf = "0b4191106b32ca91afa759f3620fc470cf61d7c2"
+SRCREV_apalis-imx6 = "0b4191106b32ca91afa759f3620fc470cf61d7c2"
+SRCBRANCH_colibri-vf = "2014.04-toradex"
+SRCBRANCH_apalis-imx6 = "2014.04-toradex"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
+ file://fw_env.config \
+"
PV = "${PR}+gitr${SRCREV}"
PR = "r0"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
-
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
inherit uboot-config
do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
}
do_install () {
- install -d ${D}${base_sbindir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -d ${D}${base_sbindir} ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv_unstripped ${D}${base_sbindir}/fw_printenv
+ ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
PACKAGE_ARCH = "${MACHINE_ARCH}"