summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
new file mode 100644
index 0000000..00bc9de
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_2016.11.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+include conf/tdx_version.conf
+
+SRCREV = "02735f400478c6e9afc432fda1149abef630657c"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "2016.11-toradex-next"
+SRC_URI += "file://fw_unlock_mmc.sh"
+
+PV = "2016.11+git${SRCPV}"
+LOCALVERSION ?= "-${TDX_VER_ITEM}"
+
+S = "${WORKDIR}/git"
+
+install_unlock_emmc() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
+do_install_append_apalis-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx7-emmc() {
+ install_unlock_emmc
+}
+