summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend53
1 files changed, 0 insertions, 53 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
index 095e4c7..22e9d2f 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
+++ b/recipes-bsp/u-boot/u-boot-toradex_2016.11.bbappend
@@ -6,56 +6,3 @@ SRCREV = "30a1208727729dae22cb42f9ba9ba17efe5e6f77"
SRCBRANCH = "2016.11-toradex"
SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "2016.11-toradex-next"
-
-# Hack around building two U-Boot configurations, one with, one without SPL
-# if using UBOOT_CONFIG to build more than one configuration, the current code in
-# u-boot.inc assumes all are either with or without SPL.
-compile_add() {
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- touch ${B}/${config}/${SPL_BINARY}
- done
- fi
-}
-deploy_add() {
- # if SPL is zero sized file, remove all deployed artefacts
- if [ -n "${SPL_BINARY}" ]
- then
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- if [ ! -s ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR} ]
- then
- rm -f ${DEPLOYDIR}/${SPL_IMAGE}-${type}-${PV}-${PR}
- rm -f ${DEPLOYDIR}/${SPL_BINARYNAME}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}-${type}
- rm -f ${DEPLOYDIR}/${SPL_SYMLINK}
- else
- ln -sf ${SPL_IMAGE}-${type}-${PV}-${PR} ${SPL_BINARYNAME}
- fi
- fi
- done
- unset j
- done
- unset i
- fi
- fi
-}
-do_compile_append_mx6() {
- compile_add
-}
-do_compile_append_use-mainline-bsp() {
- compile_add
-}
-do_deploy_append_mx6() {
- deploy_add
-}
-do_deploy_append_use-mainline-bsp() {
- deploy_add
-}