summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2018.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2018.03.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2018.03.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2018.03.bb b/recipes-bsp/u-boot/u-boot-toradex_2018.03.bb
new file mode 100644
index 0000000..052afa2
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2018.03.bb
@@ -0,0 +1,33 @@
+SUMMARY = "U-Boot bootloader with support for Toradex i.MX8 SoM"
+require recipes-bsp/u-boot/u-boot.inc
+inherit pythonnative
+
+PROVIDES += "u-boot"
+DEPENDS_append = " python dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+UBOOT_SRC ?= "git://git.toradex.com/u-boot-toradex.git;protocol=https"
+SRC_URI = "${UBOOT_SRC};branch=${SRCBRANCH}"
+
+SRCREV = "d8881436c79c2ace86c6e06db23678c79b5d52f6"
+SRCBRANCH = "toradex_imx_v2018.03_4.14.78_1.0.0_ga-bringup"
+SRCREV_use-head-next = "${AUTOREV}"
+SRCBRANCH_use-head-next = "toradex_imx_v2018.03_4.14.78_1.0.0_ga-bringup"
+
+S = "${WORKDIR}/git"
+
+inherit fsl-u-boot-localversion
+
+LOCALVERSION ?= "-${SRCBRANCH}"
+
+BOOT_TOOLS = "imx-boot-tools"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+#COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
+COMPATIBLE_MACHINE = "(mx8)"
+
+UBOOT_NAME_mx6 = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"
+UBOOT_NAME_mx7 = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"
+UBOOT_NAME_mx8 = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"