summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2019.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2019.07.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
new file mode 100644
index 0000000..6e08268
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
@@ -0,0 +1,20 @@
+require u-boot-toradex-common.inc
+require recipes-bsp/u-boot/u-boot.inc
+require recipes-bsp/u-boot/u-boot-toradex-initial-env.inc
+
+DEPENDS += "bc-native dtc-native"
+
+# U-Boot is flashed 1k into a NAND block, create a binary which prepends
+# U-boot with 1k of zeros to ease flashing
+
+nand_padding () {
+ dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx > u-boot-nand.imx
+}
+
+do_compile_append_colibri-imx6ull () {
+ nand_padding
+}
+
+do_compile_append_colibri-imx7 () {
+ nand_padding
+}