summaryrefslogtreecommitdiff
path: root/recipes-fsl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb b/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb
new file mode 100644
index 0000000..94ff260
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-gpu-libs.bb
@@ -0,0 +1,19 @@
+# Copyright (C) 2016 Toradex AG
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Deploys Vivante GPU libraries, even if no package RDEPENDS on them"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = " \
+ libgl-mx6 \
+ libgles-mx6 \
+ libgles2-mx6 \
+ libopenvg-mx6 \
+ libvdk-mx6 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'xserver-xorg-extension-viv-autohdmi', \
+ '', d), d)} \
+"