summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend40
1 files changed, 35 insertions, 5 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index c92a3c6..0fdba76 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -1,8 +1,3 @@
-INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \
- use-g2d=1 \
-"
-
-
uncomment() {
# already uncommented, do nothing
if ! (grep "^$1" $2); then
@@ -12,3 +7,38 @@ uncomment() {
sed -i -e 's,^#'"$1"','"$1"',g' $2
fi
}
+
+
+configure_noidle() {
+ sed -i '/idle-time=0/d' ${D}${sysconfdir}/xdg/weston/weston.ini
+ sed -i '/^\[core\]/a idle-time=0' ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
+# Prevent weston from going to sleep
+do_install_append_upstream() {
+ configure_noidle
+}
+
+configure_pixman() {
+ sed -i '/use-pixman=true/d' ${D}${sysconfdir}/xdg/weston/weston.ini
+ sed -i '/^\[core\]/a use-pixman=true' ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
+# With upstream weston and modules without GPU weston uses a lot of
+# cpu time and becomes very unresponsive. Setting use-pixman=true works
+# around it.
+do_install_append_upstream_colibri-imx6ull() {
+ configure_pixman
+}
+
+do_install_append_upstream_colibri-imx6ull-emmc() {
+ configure_pixman
+}
+
+do_install_append_upstream_colibri-imx7() {
+ configure_pixman
+}
+
+do_install_append_upstream_colibri-imx7-emmc() {
+ configure_pixman
+}