summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex_4.14.78.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-toradex_4.14.78.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex_4.14.78.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_4.14.78.bb b/recipes-kernel/linux/linux-toradex_4.14.78.bb
new file mode 100644
index 0000000..7a0a6f7
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_4.14.78.bb
@@ -0,0 +1,45 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017-2018 NXP
+# Copyright 2018 Toradex AG
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Linux Kernel provided and supported by Toradex"
+DESCRIPTION = "Linux Kernel provided and supported by Toradex based on NXP"
+
+require recipes-kernel/linux/linux-imx.inc
+require recipes-kernel/linux/linux-toradex_${PV}.inc
+
+DEPENDS += "lzop-native bc-native"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx:"
+SRC_URI += "file://0001-uapi-Add-ion.h-to-userspace.patch"
+
+DEFAULT_PREFERENCE = "1"
+
+DO_CONFIG_V7_COPY = "no"
+DO_CONFIG_V7_COPY_mx6 = "yes"
+DO_CONFIG_V7_COPY_mx7 = "yes"
+DO_CONFIG_V7_COPY_mx8 = "no"
+
+addtask copy_defconfig after do_unpack before do_preconfigure
+do_copy_defconfig () {
+ install -d ${B}
+ if [ ${DO_CONFIG_V7_COPY} = "yes" ]; then
+ # copy latest imx_v7_defconfig to use for mx6, mx6ul and mx7
+ mkdir -p ${B}
+ cp ${S}/arch/arm/configs/imx_v7_defconfig ${B}/.config
+ cp ${S}/arch/arm/configs/imx_v7_defconfig ${B}/../defconfig
+ else
+ # copy latest defconfig to use for mx8
+ mkdir -p ${B}
+ cp ${S}/arch/arm64/configs/defconfig ${B}/.config
+ cp ${S}/arch/arm64/configs/defconfig ${B}/../defconfig
+ fi
+}
+
+# Currently only ported for i.MX8 based SoMs
+#COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
+COMPATIBLE_MACHINE = "(mx8)"
+EXTRA_OEMAKE_append_mx6 = " ARCH=arm"
+EXTRA_OEMAKE_append_mx7 = " ARCH=arm"
+EXTRA_OEMAKE_append_mx8 = " ARCH=arm64"