summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-12-29 14:20:54 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commit2c514ff4193274546fb3cb0723dd71d40f5f020a (patch)
tree38f169e4e0879c288ebad020bb3e1ed065d8da50
parentce7b9953e0f9be09ced142d96e376e7848c4c7c4 (diff)
tegrarcm-native: fix compilation not using host headers/libraries
Turns out our build was using the library from the build machine which at least on Fedora 23 seems broken. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 044b119..66b949a 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -21,11 +21,7 @@ EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
LDFLAGS_append=" -static-libstdc++"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
-
-do_compile () {
- oe_runmake CPPFLAGS=-I${includedir}/cryptopp || die "make failed"
-}
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32 -I${includedir}/cryptopp'"
S = "${WORKDIR}/git"