summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-04-09 19:23:47 +0300
committerOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-05-14 21:30:36 +0300
commit6b2c3e6fba507d76bc318c6aba6fa8a5f5c1a558 (patch)
tree4a6d64118dc9488e6ff534a8b1159bb21fe11fc5
parent622eebbcfd5638b789df0dfa3a263959ba500531 (diff)
linux-toradex-mainline: add backport-5.4 support
Add the patches that fix interferences of kernel modules with backported modules. Related-to: ELB-2724 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-4.14/0036-tegra_defconfig-fix-ip-firewall-bpf-cgroup.patch43
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-4.14/0037-wireless-make-wireless_ext-and-wext_priv-storable.patch39
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-4.14/0038-ARM-apalis-tk1-mainline-disable-wireless-drivers.patch122
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-4.14/0039-ARM-apalis-tk1-mainline-enable-options-for-backport.patch31
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_4.14.bb6
5 files changed, 240 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-4.14/0036-tegra_defconfig-fix-ip-firewall-bpf-cgroup.patch b/recipes-kernel/linux/linux-toradex-mainline-4.14/0036-tegra_defconfig-fix-ip-firewall-bpf-cgroup.patch
new file mode 100644
index 0000000..39cbe26
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-4.14/0036-tegra_defconfig-fix-ip-firewall-bpf-cgroup.patch
@@ -0,0 +1,43 @@
+From 41f019dcce7ffb42d9c9aaa9b444fce1b0762456 Mon Sep 17 00:00:00 2001
+Message-Id: <41f019dcce7ffb42d9c9aaa9b444fce1b0762456.1577320580.git.marcel.ziswiler@toradex.com>
+In-Reply-To: <51ce88652e0414c1457e27001e5a1008f51ea0b8.1577320580.git.marcel.ziswiler@toradex.com>
+References: <51ce88652e0414c1457e27001e5a1008f51ea0b8.1577320580.git.marcel.ziswiler@toradex.com>
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Wed, 14 Aug 2019 13:12:05 +0200
+Subject: [PATCH 36/36] tegra_defconfig: fix ip firewall (bpf/cgroup)
+
+This fixes the following systemd error during boot:
+
+[ 4.225226] systemd[1]: File /lib/systemd/system/systemd-journald.
+ service:36 configures an IP firewall (IPAddressDeny=any), but the local
+ system does not support BPF/cgroup based firewalling.
+[ 4.242360] systemd[1]: Proceeding WITHOUT firewalling in effect!
+ (This warning is only shown for the first loaded unit using IP
+ firewalling.)
+
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+(similar to arm64 commit cfbad309c60a13bb7fb0ad4b1139a52d485db0cd)
+(similar to arm commit fff496c2a1bd08bb4987232c9f3f4b6704bd3146)
+---
+ arch/arm/configs/tegra_defconfig | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/arm/configs/tegra_defconfig b/arch/arm/configs/tegra_defconfig
+index e8c9bdafa1b9..1913990c3571 100644
+--- a/arch/arm/configs/tegra_defconfig
++++ b/arch/arm/configs/tegra_defconfig
+@@ -9,9 +9,11 @@ CONFIG_CGROUP_SCHED=y
+ CONFIG_RT_GROUP_SCHED=y
+ CONFIG_CGROUP_FREEZER=y
+ CONFIG_CGROUP_CPUACCT=y
++CONFIG_CGROUP_BPF=y
+ CONFIG_CGROUP_DEBUG=y
+ CONFIG_BLK_DEV_INITRD=y
+ # CONFIG_ELF_CORE is not set
++CONFIG_BPF_SYSCALL=y
+ CONFIG_EMBEDDED=y
+ CONFIG_PERF_EVENTS=y
+ CONFIG_SLAB=y
+--
+2.24.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline-4.14/0037-wireless-make-wireless_ext-and-wext_priv-storable.patch b/recipes-kernel/linux/linux-toradex-mainline-4.14/0037-wireless-make-wireless_ext-and-wext_priv-storable.patch
new file mode 100644
index 0000000..c5d585c
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-4.14/0037-wireless-make-wireless_ext-and-wext_priv-storable.patch
@@ -0,0 +1,39 @@
+From 595edde30ccad4f83a5693f7ca77c68af07f0569 Mon Sep 17 00:00:00 2001
+From: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+Date: Thu, 16 Apr 2020 11:03:54 +0300
+Subject: [PATCH 1/3] wireless: make wireless_ext and wext_priv storable
+
+The config option WIRELESS_EXT and WEXT_PRIV use to build external
+drivers, such as backports. Make these options storable in config file
+to be able to set them independently.
+
+Related-to: ELB-2388
+Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+---
+
+ net/wireless/Kconfig | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/net/wireless/Kconfig b/net/wireless/Kconfig
+index 6c606120abfe..9fa6e6d34689 100644
+--- a/net/wireless/Kconfig
++++ b/net/wireless/Kconfig
+@@ -1,5 +1,5 @@
+ config WIRELESS_EXT
+- bool
++ bool "WIRELESS_EXT - wireless core extensions"
+
+ config WEXT_CORE
+ def_bool y
+@@ -14,7 +14,7 @@ config WEXT_SPY
+ bool
+
+ config WEXT_PRIV
+- bool
++ bool "WEXT_PRIV - Wireless Extensions priv API"
+
+ config CFG80211
+ tristate "cfg80211 - wireless configuration API"
+--
+2.20.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline-4.14/0038-ARM-apalis-tk1-mainline-disable-wireless-drivers.patch b/recipes-kernel/linux/linux-toradex-mainline-4.14/0038-ARM-apalis-tk1-mainline-disable-wireless-drivers.patch
new file mode 100644
index 0000000..4294b05
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-4.14/0038-ARM-apalis-tk1-mainline-disable-wireless-drivers.patch
@@ -0,0 +1,122 @@
+From f873b60f8e5231841251598e2d38d69bac6e977d Mon Sep 17 00:00:00 2001
+From: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+Date: Thu, 9 Apr 2020 20:56:48 +0300
+Subject: [PATCH 2/3] ARM: apalis-tk1-mainline: disable wireless drivers
+
+Disabling all wireless drivers and cfg80211 module makes able
+to completely avoid interferences with backported drivers.
+
+Related-to: ELB-2388
+Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+---
+
+ arch/arm/configs/tegra_defconfig | 41 +++++++++++++++++---------------
+ 1 file changed, 22 insertions(+), 19 deletions(-)
+
+diff --git a/arch/arm/configs/tegra_defconfig b/arch/arm/configs/tegra_defconfig
+index e8c9bdafa1b9..385832bf67c5 100644
+--- a/arch/arm/configs/tegra_defconfig
++++ b/arch/arm/configs/tegra_defconfig
+@@ -18,6 +18,7 @@ CONFIG_SLAB=y
+ CONFIG_MODULES=y
+ CONFIG_MODULE_UNLOAD=y
+ CONFIG_MODULE_FORCE_UNLOAD=y
++CONFIG_MODULE_SIG=y
+ # CONFIG_BLK_DEV_BSG is not set
+ CONFIG_PARTITION_ADVANCED=y
+ # CONFIG_IOSCHED_DEADLINE is not set
+@@ -29,7 +30,6 @@ CONFIG_PCI_MSI=y
+ CONFIG_PCI_TEGRA=y
+ CONFIG_SMP=y
+ CONFIG_PREEMPT=y
+-CONFIG_AEABI=y
+ CONFIG_HIGHMEM=y
+ CONFIG_CMA=y
+ CONFIG_ZBOOT_ROM_TEXT=0x0
+@@ -70,8 +70,6 @@ CONFIG_BT_RFCOMM=y
+ CONFIG_BT_BNEP=y
+ CONFIG_BT_HIDP=y
+ CONFIG_BT_HCIBTUSB=m
+-CONFIG_CFG80211=y
+-CONFIG_MAC80211=y
+ CONFIG_RFKILL=y
+ CONFIG_RFKILL_INPUT=y
+ CONFIG_RFKILL_GPIO=y
+@@ -105,21 +103,22 @@ CONFIG_USB_PEGASUS=y
+ CONFIG_USB_USBNET=y
+ CONFIG_USB_NET_SMSC75XX=y
+ CONFIG_USB_NET_SMSC95XX=y
+-CONFIG_ATH9K=m
+-CONFIG_ATH9K_CHANNEL_CONTEXT=y
+-CONFIG_ATH9K_HTC=m
+-CONFIG_ATH10K=m
+-CONFIG_ATH10K_PCI=m
++# CONFIG_WLAN_VENDOR_ADMTEK is not set
++# CONFIG_WLAN_VENDOR_ATH is not set
+ # CONFIG_WLAN_VENDOR_ATMEL is not set
+-CONFIG_BRCMFMAC=m
+-CONFIG_IWLWIFI=m
+-CONFIG_IWLDVM=m
+-CONFIG_IWLMVM=m
+-CONFIG_RT2X00=y
+-CONFIG_RT2800USB=m
+-CONFIG_RTL_CARDS=m
+-CONFIG_RTL8192CU=m
+-CONFIG_RSI_91X=m
++# CONFIG_WLAN_VENDOR_BROADCOM is not set
++# CONFIG_WLAN_VENDOR_CISCO is not set
++# CONFIG_WLAN_VENDOR_INTEL is not set
++# CONFIG_WLAN_VENDOR_INTERSIL is not set
++# CONFIG_WLAN_VENDOR_MARVELL is not set
++# CONFIG_WLAN_VENDOR_MEDIATEK is not set
++# CONFIG_WLAN_VENDOR_RALINK is not set
++# CONFIG_WLAN_VENDOR_REALTEK is not set
++# CONFIG_WLAN_VENDOR_RSI is not set
++# CONFIG_WLAN_VENDOR_ST is not set
++# CONFIG_WLAN_VENDOR_TI is not set
++# CONFIG_WLAN_VENDOR_ZYDAS is not set
++# CONFIG_WLAN_VENDOR_QUANTENNA is not set
+ CONFIG_INPUT_JOYDEV=y
+ CONFIG_INPUT_EVDEV=y
+ CONFIG_KEYBOARD_GPIO=y
+@@ -245,9 +244,11 @@ CONFIG_MMC_BLOCK_MINORS=16
+ CONFIG_MMC_SDHCI=y
+ CONFIG_MMC_SDHCI_PLTFM=y
+ CONFIG_MMC_SDHCI_TEGRA=y
++CONFIG_NEW_LEDS=y
+ CONFIG_LEDS_CLASS=y
+ CONFIG_LEDS_GPIO=y
+ CONFIG_LEDS_PWM=y
++CONFIG_LEDS_TRIGGERS=y
+ CONFIG_LEDS_TRIGGER_TIMER=y
+ CONFIG_LEDS_TRIGGER_ONESHOT=y
+ CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+@@ -267,7 +268,6 @@ CONFIG_RTC_DRV_TEGRA=y
+ CONFIG_DMADEVICES=y
+ CONFIG_TEGRA20_APB_DMA=y
+ CONFIG_STAGING=y
+-CONFIG_R8188EU=m
+ CONFIG_MFD_NVEC=y
+ CONFIG_KEYBOARD_NVEC=y
+ CONFIG_SERIO_NVEC_PS2=y
+@@ -305,7 +305,6 @@ CONFIG_SQUASHFS=m
+ CONFIG_SQUASHFS_FILE_DIRECT=y
+ CONFIG_SQUASHFS_DECOMP_MULTI_PERCPU=y
+ CONFIG_SQUASHFS_XATTR=y
+-CONFIG_SQUASHFS_ZLIB=y
+ CONFIG_SQUASHFS_LZ4=y
+ CONFIG_SQUASHFS_LZO=y
+ CONFIG_SQUASHFS_XZ=y
+@@ -327,5 +326,9 @@ CONFIG_DEBUG_MUTEXES=y
+ CONFIG_DEBUG_SG=y
+ CONFIG_DEBUG_LL=y
+ CONFIG_EARLY_PRINTK=y
++CONFIG_CRYPTO_CCM=y
++CONFIG_CRYPTO_GCM=y
++CONFIG_CRYPTO_MICHAEL_MIC=m
++CONFIG_CRYPTO_ARC4=y
+ CONFIG_CRYPTO_TWOFISH=y
+ CONFIG_CRC_CCITT=y
+--
+2.20.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline-4.14/0039-ARM-apalis-tk1-mainline-enable-options-for-backport.patch b/recipes-kernel/linux/linux-toradex-mainline-4.14/0039-ARM-apalis-tk1-mainline-enable-options-for-backport.patch
new file mode 100644
index 0000000..a06778b
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-4.14/0039-ARM-apalis-tk1-mainline-enable-options-for-backport.patch
@@ -0,0 +1,31 @@
+From b788eaedd789c2fd56c5d249400b57055ea9f880 Mon Sep 17 00:00:00 2001
+From: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+Date: Thu, 16 Apr 2020 11:08:45 +0300
+Subject: [PATCH 3/3] ARM: apalis-tk1-mainline: enable options for backports
+
+Enable WIRELESS_EXT and WEXT_PRIV options for the backported
+rtl81288eu driver.
+
+Related-to: ELB-2388
+Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
+---
+
+ arch/arm/configs/tegra_defconfig | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/arm/configs/tegra_defconfig b/arch/arm/configs/tegra_defconfig
+index 385832bf67c5..49255fc099af 100644
+--- a/arch/arm/configs/tegra_defconfig
++++ b/arch/arm/configs/tegra_defconfig
+@@ -70,6 +70,8 @@ CONFIG_BT_RFCOMM=y
+ CONFIG_BT_BNEP=y
+ CONFIG_BT_HIDP=y
+ CONFIG_BT_HCIBTUSB=m
++CONFIG_WIRELESS_EXT=y
++CONFIG_WEXT_PRIV=y
+ CONFIG_RFKILL=y
+ CONFIG_RFKILL_INPUT=y
+ CONFIG_RFKILL_GPIO=y
+--
+2.20.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline_4.14.bb b/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
index 8ca4feb..42abb82 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
@@ -48,7 +48,11 @@ GENERIC_PATCHES = " \
file://0031-apalis-tk1-force-fixed-ids-for-sdmmc-controllers.patch \
file://0032-apalis-tk1-fix-pcie-reset-for-reliable-gigabit-ether.patch \
file://0033-apalis-tk1-mfd-k20-supporte-for-fw-version-1.3.patch \
- file://0034-apalis-tk1-mfd-k20-update-supported-fw-version-to-1..patch \
+ file://0034-apalis-tk1-mfd-k20-update-supported-fw-version-to-1..patch \
+ file://0036-tegra_defconfig-fix-ip-firewall-bpf-cgroup.patch \
+ file://0037-wireless-make-wireless_ext-and-wext_priv-storable.patch \
+ file://0038-ARM-apalis-tk1-mainline-disable-wireless-drivers.patch \
+ file://0039-ARM-apalis-tk1-mainline-enable-options-for-backport.patch \
"
MACHINE_PATCHES = " \
"