summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-15 14:06:51 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 19:03:44 +0100
commit0fcadf830568924601ede4242b031d34aa4a5c09 (patch)
tree8599eff20a819e52a8aa837ca76d3e4fc2352e7d
parent934e4c9c4891f31d25bf0cb16ed8755d5b624ded (diff)
eglinfo: remove T20/T30 and refresh patch to cleanly apply
With the stricter OE rules the 0001-Check-for-libegl-using-pkg-config.patch from openembedded-core does no longer apply to the newer git hash set in the bbappend. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/eglinfo/eglinfo-x11_%.bbappend8
-rw-r--r--recipes-graphics/eglinfo/files/0001-Check-for-libegl-using-pkg-config.patch34
2 files changed, 34 insertions, 8 deletions
diff --git a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
index 38f2969..f554535 100644
--- a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
+++ b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
@@ -1,11 +1,3 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
-
-# Set Tegra specific dependencies and device type
-DEPENDS_append_tegra = " virtual/libgles2"
-EGLINFO_DEVICE_tegra = "generic"
-
SRCREV = "223817ee37988042db7873cfb5b2e899dfe35c10"
-
-SRC_URI_append_tegra = " file://eglinfo.patch"
diff --git a/recipes-graphics/eglinfo/files/0001-Check-for-libegl-using-pkg-config.patch b/recipes-graphics/eglinfo/files/0001-Check-for-libegl-using-pkg-config.patch
new file mode 100644
index 0000000..3c6a31b
--- /dev/null
+++ b/recipes-graphics/eglinfo/files/0001-Check-for-libegl-using-pkg-config.patch
@@ -0,0 +1,34 @@
+From 95043bcd491cf99a337fbf077c7dfd5a4f66c167 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Aug 2018 15:46:53 -0700
+Subject: [PATCH] Check for libegl using pkg-config
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ wscript | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/wscript b/wscript
+index 0f6ec53..401f62e 100644
+--- a/wscript
++++ b/wscript
+@@ -174,14 +174,9 @@ def configure_raspberrypi_device(conf, platform):
+ else:
+ conf.fatal('Unsupported Raspberry Pi platform "%s"' % platform)
+ return
+- conf.check_cxx(mandatory = 1, lib = ['GLESv2', 'EGL', 'bcm_host'], uselib_store = 'EGL')
++ conf.check_cfg(package='egl', args='--libs --cflags')
+ import os
+ sysroot = conf.options.sysroot + conf.options.prefix
+- std_include_path = os.path.join(sysroot, 'include')
+- vcos_pthread_path = os.path.join(sysroot, 'include/interface/vcos/pthreads')
+- vcms_host_path = os.path.join(sysroot, 'include/interface/vmcs_host/linux')
+- if not conf.check_cxx(mandatory = 0, header_name = ['vcos_platform_types.h', 'EGL/egl.h', 'bcm_host.h'], includes = [vcos_pthread_path, vcms_host_path, std_include_path], uselib_store = 'EGL'):
+- conf.fatal('Check if --prefix and --sysroot are set correctly.')
+ conf.env['WITH_APIS'] = []
+ if check_gles2(conf):
+ conf.env['WITH_APIS'] += ['GLES1', 'GLES2']
+--
+2.13.6
+