summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2019-09-07 21:45:36 +0800
committerMing Liu <ming.liu@toradex.com>2019-09-07 21:45:36 +0800
commit45dfc4506091628efaa92569c1807e025f416222 (patch)
tree5c7a1c9d7d267edd7190c1ddf7ba65c16bee3957
parent942156423c8d1d13081cb9c1ed1f1d56cfbbe87e (diff)
linux: drop linux-toradex-mainline.inc
This file is conflicting with another include file with same name in meta-toradex-bsp-common layer, and no recipe is actually including this file, so drop it. Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc110
1 files changed, 0 insertions, 110 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
deleted file mode 100644
index 56a8dd1..0000000
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ /dev/null
@@ -1,110 +0,0 @@
-SUMMARY = "Linux Kernel for Toradex Tegra based modules"
-SECTION = "kernel"
-LICENSE = "GPLv2"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-inherit kernel siteinfo
-
-# Try to build & install perf
-#require recipes-kernel/linux/linux-tools.inc
-
-RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
-
-# Enable OABI compat for people stuck with obsolete userspace
-# ARM_KEEP_OABI ?= "1"
-
-# Quirk for udev greater or equal 141
-UDEV_GE_141 ?= "0"
-
-# Kernel bootlogo is distro-specific (default is OE logo).
-# Logo resolution (qvga, vga, ...) is machine-specific.
-LOGO_SIZE ?= "."
-
-# Support for binary device tree generation
-
-FILES_kernel-devicetree = "/boot/devicetree*"
-
-#KERNEL_DEVICETREE to be specified from machine configuration
-
-KERNEL_DEVICETREE_FLAGS = "-R 8 -S 0x3000"
-
-CORTEXA8FIXUP ?= "yes"
-
-python __anonymous () {
-
- import bb
-
- devicetree = d.getVar('KERNEL_DEVICETREE', True) or ''
- if devicetree:
- depends = d.getVar("DEPENDS", True)
- d.setVar("DEPENDS", "%s dtc-native" % depends)
- packages = d.getVar("PACKAGES", True)
- d.setVar("PACKAGES", "%s kernel-devicetree" % packages)
-}
-
-do_configure_append() {
- if test -e scripts/Makefile.fwinst ; then
- sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
- fi
-}
-
-# bitbake.conf only prepends PARALLEL make in tasks called do_compile, which isn't the case for compile_modules
-# So explicitly enable it for that in here
-EXTRA_OEMAKE = "${PARALLEL_MAKE} "
-
-do_uboot_mkimage_prepend() {
- mkdir arch/${ARCH}/boot/ || true
-}
-
-do_install_append() {
- oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
-}
-
-PACKAGES =+ "kernel-headers"
-FILES_kernel-headers = "${exec_prefix}/src/linux*"
-
-do_devicetree_image() {
- if test -n "${KERNEL_DEVICETREE}" ; then
- dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree ${KERNEL_DEVICETREE}
- install -d ${D}/boot
- install -m 0644 devicetree ${D}/boot/devicetree-${KERNEL_VERSION}
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 devicetree ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb
- cd ${DEPLOY_DIR_IMAGE}
- rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- ln -sf ${KERNEL_IMAGE_BASE_NAME}.dtb ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- fi
-}
-
-do_devicetree_image_tegra124() {
-}
-
-addtask devicetree_image after do_install before do_package do_deploy
-
-pkg_postinst_kernel-devicetree () {
- cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree devicetree devicetree-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
-}
-
-pkg_postrm_kernel-devicetree () {
- cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree devicetree-${KERNEL_VERSION} || true
-}
-
-# Automatically depend on lzop-native if CONFIG_KERNEL_LZO is enabled
-python () {
- try:
- defconfig = bb.fetch2.localpath('file://defconfig', d)
- except bb.fetch2.FetchError:
- return
-
- try:
- configfile = open(defconfig)
- except IOError:
- return
-
- if 'CONFIG_KERNEL_LZO=y\n' in configfile.readlines():
- depends = d.getVar('DEPENDS', False)
- d.setVar('DEPENDS', depends + ' lzop-native')
-}