summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-11-21 14:55:12 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-20 17:08:43 +0100
commit3b9027d4f0fcc07200d31fe8f53c0a38d8f24f0d (patch)
tree4327ff44365f156064f661bc99e3a5b14d132cd1
parent5afad2df8e72c1075c2fedd49fd95a904ec27fd4 (diff)
xerver-xorg: update to 1.17.4
Based on 1.17.2 from meta-jetson-tk1. Dropped patch no longer applicable. Also make sure that 1.17.2 is not choosen for any machine due to the higher layer priority of meta-jetson-tk1. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
-rwxr-xr-xjetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch25
-rw-r--r--jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.2.bbappend26
-rwxr-xr-xjetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb41
-rw-r--r--jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend23
4 files changed, 92 insertions, 23 deletions
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
new file mode 100755
index 0000000..ec0eea6
--- /dev/null
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
@@ -0,0 +1,25 @@
+This is the revised version of files/macro_tweak.patch for
+xorg-server 1.8.99.904 and newer.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+diff --git a/xorg-server.m4 b/xorg-server.m4
+index bdecf62..040fdb8 100644
+--- a/xorg-server.m4
++++ b/xorg-server.m4
+@@ -28,10 +28,12 @@ dnl
+ # Checks for the $1 define in xorg-server.h (from the sdk). If it
+ # is defined, then add $1 to $REQUIRED_MODULES.
+
++m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
++
+ AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
+ AC_REQUIRE([PKG_PROG_PKG_CONFIG])
+ SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
++ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "xorg-server.h"
+ #if !defined $1
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.2.bbappend b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.2.bbappend
index de91e1b..3b7f71c 100644
--- a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.2.bbappend
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.2.bbappend
@@ -1,23 +1,3 @@
-# always latest and greatest.
-PE_tegra124 = "99"
-
-PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
-
-COMPATIBLE_MACHINE = "(apalis-tk1|jetson-tk1|jetson-tk1-l4t)"
-
-DEPENDS_append = " libxfont"
-
-# provided by xf86-input-evdev_2.10.0
-do_install_append () {
- rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
-}
-
-#| checking for PIXMAN... yes
-#| checking for SYSTEMD_DAEMON... no
-#| configure: error: systemd support requested but no library has been found
-#| ERROR: Function failed: do_configure (log file is located at .../xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
-
-PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
-"
+# we now use 1.17.4 for TK1, do not consisder the 1.17.2 recipe for any
+# machine
+PNBLACKLIST[xserver-xorg] = "don't prefer older xserver over newer one from layer with less priority" \ No newline at end of file
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
new file mode 100755
index 0000000..9f5dbbf
--- /dev/null
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
@@ -0,0 +1,41 @@
+require recipes-graphics/xorg-xserver/xserver-xorg.inc
+
+SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
+SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
+
+# These extensions are now integrated into the server, so declare the migration
+# path for in-place upgrades.
+
+RREPLACES_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+RPROVIDES_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+RCONFLICTS_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+# provided by xf86-input-evdev_2.10.0
+do_install_append () {
+ rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
+}
+
+# override setting from xserver-xorg.inc which only applies to version 1.18.
+#| checking for PIXMAN... yes
+#| checking for SYSTEMD_DAEMON... no
+#| configure: error: systemd support requested but no library has been found
+#| ERROR: Function failed: do_configure (log file is located at /build/krm/oe-core_V2.6.2/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
+
+PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
+"
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
new file mode 100644
index 0000000..de91e1b
--- /dev/null
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
@@ -0,0 +1,23 @@
+# always latest and greatest.
+PE_tegra124 = "99"
+
+PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(apalis-tk1|jetson-tk1|jetson-tk1-l4t)"
+
+DEPENDS_append = " libxfont"
+
+# provided by xf86-input-evdev_2.10.0
+do_install_append () {
+ rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
+}
+
+#| checking for PIXMAN... yes
+#| checking for SYSTEMD_DAEMON... no
+#| configure: error: systemd support requested but no library has been found
+#| ERROR: Function failed: do_configure (log file is located at .../xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
+
+PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
+"