summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-01-21 00:35:44 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:07:00 +0200
commitbce75f118c0a45b735456a451581e083b9be046f (patch)
tree5a882c548a64d66a15bdfa31ca5c740644517989
parent786ec6f5ac344e0a1849f6afc0252d61895cfad3 (diff)
opencv4tegra: expand parameter is mandatory now
d.getVar()'s expand parameter is no longer optional and a python exception is raised in do_unpack. While at it, do not redefine the location of S and skip QA warnings caused by the already stripped binary drivers. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--jetson-tk1/recipes-bsp/binary-drivers/opencv4tegra_21.4.0.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/jetson-tk1/recipes-bsp/binary-drivers/opencv4tegra_21.4.0.bbappend b/jetson-tk1/recipes-bsp/binary-drivers/opencv4tegra_21.4.0.bbappend
index 4d233c8..d705a8c 100644
--- a/jetson-tk1/recipes-bsp/binary-drivers/opencv4tegra_21.4.0.bbappend
+++ b/jetson-tk1/recipes-bsp/binary-drivers/opencv4tegra_21.4.0.bbappend
@@ -7,6 +7,17 @@ LIC_FILES_CHKSUM = "file://usr/share/doc/libopencv4tegra-repo/copyright;md5=99d8
SRC_URI[md5sum] = "ee3ad8fb8eaafc357d5e228d61ad7123"
SRC_URI[sha256sum] = "096fb80a83c53f5e946c8106985eb147c8791b0cbe1e1fc38ebc49a3b932bf19"
+INSANE_SKIP_${PN} += "already-stripped"
+
+python do_unpack () {
+ locals = d.getVar('WORKDIR', True)
+ s = d.getVar('S', True)
+ d.setVar('WORKDIR', s)
+ d.setVar('S', s)
+ bb.build.exec_func('base_do_unpack', d)
+ d.setVar('WORKDIR', locals)
+}
+
do_install () {
cp -r ${WORKDIR}/opencv4tegra/usr ${D}
dpkg -x ${WORKDIR}/opencv4tegra/var/opencv4tegra-repo/libopencv4tegra_2.4.12.3_armhf.deb ${D}